Keyboard Input Ignored for c, h, t, and v Keys in Specific Applications Only

Every once in a great while I see this odd problem arise. I have not yet found a solution but when I do it will find a home here.

Basically what happens is I will hop over to a specific application, try to type into that application, and find that certain particular letters will do nothing. This time it was these four letters: t, h, c, and v, but I think that sounds like what it was on other occasions (though I don’t recall perfectly).

Most recently this happened in Outlook. I have seen this happen in Outlook before, but I’ve seen it happen a couple of times in Firefox and once in Opera. It is definitely not a keyboard problem, a driver issue, a problem with the specific application, or a keyboard shortcut issue—nor is it a virus or spyware.

Something as yet undetermined happens in the wonderful world of Windows XP (I have one user reporting this in the Mac OS as well) wherein those four letters are completely ignored as input. It only effects a single application when it occurs. No alt-, ctrl-, or windows- commands are executed when any of those keys are typed. I can press the same key, the t say, 100 times and absolutely nothing will happen. Then I switch to another application et voilà it works fine. For instance I’ve had to type an e-mail reply into a text editor and paste it into the reply window because I couldn’t type basic words like the.

Using associated keyboard shortcuts seems to be unaffected. As noted I was not able to type the letter v. However, I was able to use ctrl-v to paste into the reply window.

Now I know you’re going to think: “well it must be that reply window”.  Again, it’s application-wide.  I am not able to type those letters into the search boxes or contacts windows or any other place that might allow text entry—within the afflicted application.

Also, I have seen this on at least three machines where there can be no relation between them (except my smiling face reflected in the monitor).  I think I have seen this happen maybe half a dozen times in the last couple of years.

It’s easy enough to fix by restarting the afflicted application, but I am on the path for this one.  It’s stuck in my craw so I won’t be satisfied until I figure what the hell is going on.

It has come to my attention this may also effect on-screen keyboards.  Please test this in your case if you are able, and let us know your results below.

I’ll try to keep this up to date concerning my progress, but feel free to share your solutions. I’m all eyes.  (This happens rarely enough that it’s good to have others contributing data.)

(It will be useful to include four items in your comments: 1) your solution (even if temporary); 2) keys effected; 3) application(s) effected; and 4) operating system(s) involved.)

Random Solutions and Workarounds Culled from the Comments (and Elsewhere):

(In no particular order.  This may not be complete and up-to-date.)

  1. A double-tap of the Windows (or Super) key.
  2. A double-tap of specifically the right Windows key.
  3. Restart the effected application (or Explorer if effected)
  4. Reboot (last resort).
  5. “Detect and Repair” from the Help menu in Outlook (Outlook only)
  6. Press CapsLock and Shift back down to lower case (this is a per letter fix)
  7. Fn key + Windows key may toggle problem on and off.
  8. Alt key + Windows key may toggle problem on and off (especially in Win8).
  9. Region and Language —> Keyboards and Languages —> change keyboards;
    delete all keyboards other than your language and delete all instances of “Ink Correction”.  Or try changing the format setting at Format (dropdown): from English (United States) to English (United Kingdom) and click OK.
  10. Disable Sticky Keys (Control Panel —> Ease of Access Center —> Make the keyboard easier to use —> Make it easier to type —> uncheck “Turn on Sticky Keys“)
  11. Remove all keyboards from the Device Manager and reboot.
  12. Login to the effected machine via RDP and then return to the machine and login locally.
  13. Laptops may have to use the Widows key on the laptop and not a secondary keyboard.
  14. In Win7 it may be useful to check for keyboard/language changing hotkeys here Control Panel —> Region and Language —> Keyboards and Languages —> Change Keyboards —> Advanced Key Settings
  15. If you have only a left Windows key, you may attach an external keyboard which does.  Failing that, user Matan below wrote a right-Windows-key simulator which can be found here.  (Please note that I cannot guarantee the integrity of that source, so please use appropriate caution when downloading from unknown sources.)
  16. User Klode as offered another possible solution for users lacking a right-Windows key.  Open a command prompt and type first cd /d c:\tmp (then press Enter) followed by nircmd sendkeypress rwin (and press Enter).  Klode also describes how to create a shortcut for that and his comment can be found here.

If none of these work or if you have one to add yourself, comment away.

(It will be useful to include four items in your comments: 1) your solution (even if temporary); 2) keys effected; 3) application(s) effected; and 4) operating system(s) involved.)


607 thoughts on “Keyboard Input Ignored for c, h, t, and v Keys in Specific Applications Only

  1. My keys were c, h, and v…oddly similar to your problem keys. It happened after my six year old started randomly clicking things on the screen and hitting a long string of random keys on the keyboard. The keys by themselves would do nothing, but I could type the capital of each using shift, and commands all worked using alt or ctrl. I went straight for the reboot and did not save the document my son “typed” just incase it might have saved some weird settings along with it. After the reboot, all is back to normal.

  2. I’m losing keys one by one. First it was the “a” and the “s” keys, now it has spread to caps lock, enter, right arrow and some number keys. I have read about others who had this issue and changed their keyboard, but that didn’t solve the problem. I’m using a MAC pro with a flat USB keyboard, so it cannot be opened.

    1. This article is specifically about a Windows bug so it’s not likely to help you much on the Mac OS. Your issue does sound like a hardware problem, but you could test logging in with a different (new) user account to see if the problem persists.

  3. C, v, h, apostrophe, and backspace currently isn’t working for me on my computer, I’ve tested 2 keyboards… once I’ve finished watching the livestream I’m currently watching I’ll try restarting my computer. It was a problem when I came home after being gone a few hours.
    I have Windows 10

  4. Changing the format setting at Format (dropdown): from English (United States) to English (United Kingdom) and click OK.

    This works for me

  5. Wow, this problem persists after 11 years huh?
    I was using notepad, and the command prompt on Windows 10 when the C, V, and H keys stopped working, sometimes when smashing the V key by itself out of frustration it would decide to paste whatever was on the clipboard. A and S keys also gave some problems but fixed themselves suddenly. Restarted the applications, worked for about a minute and got the same problem again. Opened Google Chrome to try to find a fix but realised I couldn’t even type the problem… the same keys (C, V and H) where giving me problems in Chrome. Searched with my phone and was glad to find I wasn’t alone. None of the key combinations in this post helped me, though restarting each application again seems to have fixed the problem for now.
    Great post, it really helped me
    Thank you

  6. Still a very relevant post after all these years…
    I’ve run into this issue a few times in Windows 10 over the last few months. I usually rebooted. Today I started hunting and found this post.

    Double-tapping the right Windows key worked for me.

    I was typing a reply email in Outlook. I noticed when I was typing that something would flash briefly in the lower left of the screen (like a command window popping open and then closed real quick but not that). After this happening a few times and not affecting my typing the v key stopped working and outlook popped up the “outlok is unable to proceed with the reconversion” message reported by others.
    Trying the double-tap of the left Windows key, shift-alt, or switching applications did not help.

    I have seen this now while in a RDP session, and directly on the desktop. I don’t know how to force it to reproduce though.

  7. Windows 10, Keys C H V and BS not working in Chrome, Win+R dialog, but working in Edge, Notepad… What helps is killing ctfmon.exe using . I am now not able to switch between english and second language, but still better than using Shift C Shift for writing c (although this is not working for v – it works like Ctrl+V at least in Chrome). Very strange behaviour. Shame to MS for this bug, which is 12 years old (at minimum).

  8. My T key does not work in Chrome Remotre Desktop but it works in Teamviewer. It works on CRD on keyboard test websites but it doesn’t actually type it…

  9. Thanks for posting this article and to all who’ve responded in the comments. I had the C, V, and T not working in AutoCAD while the same keys worked in every other application I tried.
    My first thought was to blame AutoCAD since it has a history of bugs, however this article straightened me out.
    Opening the windows accessibility on-screen keyboard actually fixed the problem. Therefore, I’m confident in assigning the blame for this issue (for whatever its worth) on Windows.

  10. For us it worked to open another application, type afflicted letter there and then copy it into the application it’s not working in.

    Might be of note that we opened the second application throw the windows-start-menu which we opened with the windows-key.

Leave a Reply

Your email address will not be published. Required fields are marked *