Keyboard Input Ignored for c, h, t, and v Keys in Specific Applications Only

Every once in a great while I see this odd problem arise. I have not yet found a solution but when I do it will find a home here.

Basically what happens is I will hop over to a specific application, try to type into that application, and find that certain particular letters will do nothing. This time it was these four letters: t, h, c, and v, but I think that sounds like what it was on other occasions (though I don’t recall perfectly).

Most recently this happened in Outlook. I have seen this happen in Outlook before, but I’ve seen it happen a couple of times in Firefox and once in Opera. It is definitely not a keyboard problem, a driver issue, a problem with the specific application, or a keyboard shortcut issue—nor is it a virus or spyware.

Something as yet undetermined happens in the wonderful world of Windows XP (I have one user reporting this in the Mac OS as well) wherein those four letters are completely ignored as input. It only effects a single application when it occurs. No alt-, ctrl-, or windows- commands are executed when any of those keys are typed. I can press the same key, the t say, 100 times and absolutely nothing will happen. Then I switch to another application et voilà it works fine. For instance I’ve had to type an e-mail reply into a text editor and paste it into the reply window because I couldn’t type basic words like the.

Using associated keyboard shortcuts seems to be unaffected. As noted I was not able to type the letter v. However, I was able to use ctrl-v to paste into the reply window.

Now I know you’re going to think: “well it must be that reply window”.  Again, it’s application-wide.  I am not able to type those letters into the search boxes or contacts windows or any other place that might allow text entry—within the afflicted application.

Also, I have seen this on at least three machines where there can be no relation between them (except my smiling face reflected in the monitor).  I think I have seen this happen maybe half a dozen times in the last couple of years.

It’s easy enough to fix by restarting the afflicted application, but I am on the path for this one.  It’s stuck in my craw so I won’t be satisfied until I figure what the hell is going on.

It has come to my attention this may also effect on-screen keyboards.  Please test this in your case if you are able, and let us know your results below.

I’ll try to keep this up to date concerning my progress, but feel free to share your solutions. I’m all eyes.  (This happens rarely enough that it’s good to have others contributing data.)

(It will be useful to include four items in your comments: 1) your solution (even if temporary); 2) keys effected; 3) application(s) effected; and 4) operating system(s) involved.)

Random Solutions and Workarounds Culled from the Comments (and Elsewhere):

(In no particular order.  This may not be complete and up-to-date.)

  1. A double-tap of the Windows (or Super) key.
  2. A double-tap of specifically the right Windows key.
  3. Restart the effected application (or Explorer if effected)
  4. Reboot (last resort).
  5. “Detect and Repair” from the Help menu in Outlook (Outlook only)
  6. Press CapsLock and Shift back down to lower case (this is a per letter fix)
  7. Fn key + Windows key may toggle problem on and off.
  8. Alt key + Windows key may toggle problem on and off (especially in Win8).
  9. Region and Language —> Keyboards and Languages —> change keyboards;
    delete all keyboards other than your language and delete all instances of “Ink Correction”.  Or try changing the format setting at Format (dropdown): from English (United States) to English (United Kingdom) and click OK.
  10. Disable Sticky Keys (Control Panel —> Ease of Access Center —> Make the keyboard easier to use —> Make it easier to type —> uncheck “Turn on Sticky Keys“)
  11. Remove all keyboards from the Device Manager and reboot.
  12. Login to the effected machine via RDP and then return to the machine and login locally.
  13. Laptops may have to use the Widows key on the laptop and not a secondary keyboard.
  14. In Win7 it may be useful to check for keyboard/language changing hotkeys here Control Panel —> Region and Language —> Keyboards and Languages —> Change Keyboards —> Advanced Key Settings
  15. If you have only a left Windows key, you may attach an external keyboard which does.  Failing that, user Matan below wrote a right-Windows-key simulator which can be found here.  (Please note that I cannot guarantee the integrity of that source, so please use appropriate caution when downloading from unknown sources.)
  16. User Klode as offered another possible solution for users lacking a right-Windows key.  Open a command prompt and type first cd /d c:\tmp (then press Enter) followed by nircmd sendkeypress rwin (and press Enter).  Klode also describes how to create a shortcut for that and his comment can be found here.

If none of these work or if you have one to add yourself, comment away.

(It will be useful to include four items in your comments: 1) your solution (even if temporary); 2) keys effected; 3) application(s) effected; and 4) operating system(s) involved.)


604 thoughts on “Keyboard Input Ignored for c, h, t, and v Keys in Specific Applications Only

  1. surprisingly just had this in windows 8, problem was located to explorer but also could not type while on the main metro start menu – I use logitech slim keyboards that have no windows key on the right, tried everything finally got an old corded keyboard with a windows key on the right, double tap the RIGHT windows key and everything back to normal …. very strange and thanks for the article, still helping 5 years later!

    same keys CVH, worked with shift + caps and shortcuts but not normal type ……

    Thanks! :D

    1. Just encountered this for the first time today in Windows Explorer and Outlook 2013 on Windows 8 !!

      Double tapping the RIGHT Windows key worked for me, so many thanks for the tips :-)

  2. I found that on my windows 8 pc and office 365 the c, v, and h keys do not work after I use the windows key to make a window show on half the screen. They work again after tapping the windows key again. I noticed as well that when hit the windows key the word windows like refreshes. I think windows needs to fix this problem -_-

      1. I had never had this happen before, but yesterday I managed to do something in Windows 7 to make a Windows Explorer window expand to half the screen. Since that happened, Outlook 2010 (and only Outlook) has begun ignoring my C, V, and H keys. (T was spotty just now but came back somehow.) This has happened about 6 times in the past day, and the keys started working after restarting Outlook.

        I’m off to try a reboot, hoping that will clear out this problem.

        1. In Win7 and later you can semi-maximize an application to half the screen by dragging the title bar to the edge of the screen. This is a new feature (and one I like).

          Hope your reboot fixed the matter.

        2. Win 7 on both my work laptop and desktop started doing this yesterday but only after I use Windows Key Right/Left Arrow to maximize a window to half screen the only way to clear it seems to be to close the application and restart and don’t use Win Right/Left Arrow key.

  3. I was having the same issue recently with a Windows 8 Surface Pro along with loosing the ability to type a search straight from the start menu. What fixed it for me was going into device manager and uninstalling all the keyboards and rebooting the system.

  4. i cant type the letters H,C,V in fb post,even in this site…am pressing shift to type these words….i reloaded many times ….is tis pblm is temp r permanent…pls reply me…

  5. I just had a customer call me with this exact issue in Windows 7 with Office 2010. In particular, she was replying to an email that was in mixed languages. Part of it was in English, part was in Spanish. It seemed to begin when Outlook tried to spell/grammar check a word in the reply. I added Spanish (International Sort) to her dictionary list and closed all Office applications. When we re-opened Otulook, everythiing seemed back to normal. It’s a little soon, though, to know if it’s really gone for good. She never had a problem until today though she regularly receives and responds to multi-lingual emails.

  6. Summary: I now believe this problem is linked to the use of MSRDP. The cause is still unknown. It could be anything from malware to a hypothetical, long-standing Windows bug (some reports mention Windows XP; most Windows 7).

    Fix:Log in (again) via MSRDP: problem doesn’t exist. Log in again directly on the desktop: problem gone, across all applications. So far, anyway. Fingers crossed…

    1. I experienced the incorrect behaviour described in the article above, with c/v/h, , , etc.
    2. None of the suggestions as of 2013-04-03 made any difference.
    3. My system: Dell Precision 490 with Dell keyboard, running Windows 7 Pro 64-bit and fairly recent updates
    4. I make extensive use of built-in keyboard shortcuts, both OS-based and in-application shortcuts, notably MSRDP client (see section “Closing”, below). Examples for MSRDP client: [left blank].
    5. Third-party software: earlier in the day, I had upgraded Firefox from v19.x to the just-released v20.x.
    6. However, the problem persisted even with Firefox not running.
    7. Nothing else had been updated recently.
    8. List of third-party tools which could conceivably affect keyboard input: anti-virus, keyboard shortcut manager, screen zooming/presentation tool.
    9. First manifested in MS Outlook 2007, which hasn’t been restarted in days. It started several minutes into the creation of a new message.
    10. A Cygwin rxvt/tcsh console window was fine, and I was able to type normally inside vim (and editor).
    11. Within 20 minutes, c/v/h was broken within vim.
    12. I started four more instances of rxvt/tcsh. Two were problem free during testing, one had the problem from first instantiation, and one started problem free then acquired the problem.
    13. Unplugging and reconnecting the USB keyboard didn’t help
    14. Replacing the keyboard with another of the same model didn’t help.
    15. Even with the on-screen keyboard, affected apps had the problem with c/v/h.
    16. I exited all apps identified in step (8) above and confirmed via Task Manager that the process no longer existed.
    17. I started/stopped Firefox, started it and disabled all add-ons, stopped it again, etc. Nothing affecting the problem.
    18. At this point I started to suspect malware. Somewhat low probability though, because it would have to be poorly written malware indeed :-).
    19. I finally realized that some time before the problem started (an hour or more), I’d connected to my desktop from my laptop, via an MS Remote Desktop session and Cisco AnyConnect VPN connection. I connect this way on a fairly regular basis.

    I have used MSRDP literally for more than a decade, across at least thousands and possibly tens of thousands of sessions, some lasting minutes, some lasting weeks. I have never before seen or heard of this problem.

    However, I have had problems fairly often with stuck modifier keys when switching back and forth from MSRDP client to the local OS.

    I am interested to hear from previous commenters whether they think MSRDP was/wasn’t/might have been involved.


    1. Argh. To moderator: I forgot to avoid angle brackets when listing key names, thus all text from #4 onward is damaged. If you have access to the raw text I entered, please feel free to correct it yourself, or if you prefer to delete and have me re-submit, let me know via email.
      — klode

      1. Hello.

        I just got this problem, on Microsoft Lync and Excel (but not Outlook, the 3 were open simultaneously).
        The on-screen keyboard didn’t help, as the result was the same (no c v and h).
        The double tap on right Windows key fixed it.
        I have no idea on how this started, but definitely it is not the first time…

        1) your solution (even if temporary) – Right Windows key (in an external keyboard, as my laptop only has 1 Windows key, on the left, which didn’t work)
        2) keys effected – c, v and h
        3) application(s) effected – Microsoft Lync 2010 and Excel 2010
        4) operating system(s) involved – Windows 7 64-bit (updated as of 2014-01-09)


    2. I am having the same exact issue. And yes, using Cisco AnyConnect VPN…

      I use the VNP to login to my work machine as I work remotely. The other day I logged in and I couldn’t type c,h,v on my remote machine. I had the remote machine rebooted by someone on site and still had the problem. I was told it was a stuck Windows key. I pressed my Windows key locally on my laptop and it cleared up the remote desktop problem.

      However, on my local machine – my laptop – I now experience intermittent failures of the h,c,v keys in certain applications. It happens frequently now and when it does I have to restart the affected application. It doesn’t seem to care which application – it just starts affecting one.

      I am with you: I think this has something to do with Cisco AnyConnect VPN client, but I am unsure what remedy to pursue at this juncture.

    3. If this is happening in a RDP session, minimize the session and bring it back up. I have had weird issues happen to users who are RDPed into their machines and when these random issues happen, it usually is fixed by a simple minimizing of the RDP session.

  7. Last comment today, I promise. To JamesIsIn: thanks for maintaining this article. It would be helpful if your list of possible fixes included the last date it was updated, so we could search later comments manually if necessary.
    — klode

    1. I manually approve comments and update as new information arrives, so that ought to be sufficient. (Usually the bottle-neck is getting me to read and approve the comments and not in adjusting the content of the article.) Thanks for the suggestion nonetheless.

  8. Hi,

    I have just faced the same issue (CVH keys are not working in Firefox & VS2008 IDE). Just google about the issue & I surprisingly got this link and did double hit Windows key from my keyboard and everything gets normal.

    Thanks for such a nice article !!!

  9. I just spoke to a client on a Windows 7 x64 OS using Outlook through a RDP who was experiencing this issue. I logged into his computer via LogMeIn and was able to reproduce the problem through a remotes session. The issue is obviously not hardware related. I thought perhaps a stray macro was making it happen, but he has no macros. Restarted Outlook in Safe Mode, and everything was back to normal, and when I restarted Outlook in normal mode, everything was fine, so I can’t say that Safe Mode made any difference at all. Definitely a weird issue, and no definitive explanation in any KB’s I’ve searched.

    Thanks MS!

  10. At least I am not alone! Sometimes I lose CVH keys when I am working on Word 2013. I use an iMac 27 inch, the latest one! I installed Windows 8 on Bootcamp who was only available for this model few weeks ago.

    I have few other issues (I know it is not the purpose of this post, but I need to talk to somebody, sorry) : sometime the keyboard completely stop working in Firefox (I am not alone to have this issue but no solution exist), I also have some issues with the mouse – the magic mouse get its own life and scroll/move/select option on its own (not alone, but no solution), the Logitech mouse I finally use is “very tired” and some time needs few microseconds to notice I move it!! I am so fed up :-( I need to talk to somebody !!


    1. Yeah, computers can be very frustrating. Bootcamp can be particularly challenging. I would post your questions to Bootcamp specific or even Windows specific forums. Someone else is likely experiencing the same thing and may have some advice.

      1. I managed to have my CVH keys back by hitting the Windows key, which is Command key on a mac keyboard. Not very please with that but for now…

  11. I read through this entire article and kept trying to use the right Windows key – tapping it twice like was stated. Not until I tapped on the Windows key on the LAPTOP keyboard did it work. I could finally type c, v, and h on both my regular keyboard and my laptop keyboard when I am at home. Thanks! This was driving me crazy!

  12. Just had the same problem, and double tapping the windows key seems to have fixed it.

    The issue was isolated to Word 2013, and only in the bulleted line I was typing… It seems to have happened after my cat walked accross my keyboard, and I think he hit one of the following keys is some type of combination: Ctrl, Fn, Windows key and/or alt.

    Thanks for the help!

  13. James, thanks so much, the Windows key did the trick for me. Truly astounding, weird condition, where the same 3 keys stop operating for people for no apparent reason, and can then be fixed so simply, but unintuitively. In my case, they stopped operating only in Outlook.

  14. I had the issue using Windows 8 Surface Pro. It’s been resolved after using a few of the tricks on this page. Thanks. :)

  15. I have a problem with the buttons C D E i tried all your solutions but nothing worked in win 7 ultimate at all applications (games,chrome,firefox,writing folders’ names) wheb i play any game i press C D E but nothing happens now i’m writing from the windows keyboard please help

  16. I was having this problem with the Microsoft Windows Vista. I guess, it’s whatever the newest one with the icons and can swipe back and forth. ANYWAYS . Was in Microsoft Word and having key issues for the same letters, after trying several tips on here and only some being temporary fix. I decided at bottom of keyboard to press Fn+Windows button next to it, and it solved it for me. Hope it helps for others!

  17. I had the same problem for a while, even using on-screen-keyboard produced the same issue, thereby completely eliminating a hardware issue. I had this problem quite often in “Remote Desktop,” and often when I was on-call and remoting into my desktop computer at work. The reply from “amirhp” in the following blog post is what fixed it for me.

    Step 2 isn’t quite clear if you’re not familiar with remote desktop, so to get to it, you open remote desktop (either using the start menu, or start > run > mstsc). Go to the “Local Resources” tab, and make the changes “amir” suggests. It worked right away for me.

    The best workaround that always works for me is:

    1. Close the RD window
    2. Open new RD but make sure the “Apply Windows key Combinations” is set to “On the remote computer”
    3. Now press the Ctrl+Alt+End and lock the computer
    4. Log in again and it should work.

    1. Well, if you are seeing what’s on the other post (Windows key acting like it’s stuck) that’s a different (if equally annoying) issue. When a remote session has the Windows key stick I can usually fix that by hitting the Windows key several times. Also, I am dubious of that author’s claim that Win-L from the console causes the Win key to stick for RDP. I do this all the time at work and never see that happen (or at least close enough to never to doubt this as the cause).

      Thanks for writing, Tom.

  18. I had keys CVH suddenly stop working from time to time, with apparently no pattern, but in my case it wasn’t app-specific as in your example but global for the system. This thread helped me with the Fn key + Windows key solution. Thanks for that. In my case it didn’t toggle the problem as described – but it fixed it immediately. I am using Windows 7 Ultimate 64-bit on an Alienware laptop. Pressing Windows key multiple times which I tried prior to the other solution didn’t help (there is only the left one on this keyboard).

    1. It is unusual to see this issue globally, but I’m glad you were able to solve it. (Incidentally, I’ve never been able to toggle this problem on and off.) Thanks for your feedback.

  19. I had the exact same problem but not the “t” – just c, h and v and I think the “l” as well- works fine in “word” but not on websites, facebook, text entries online, etc. as many others mentioned. I am in Windows 7 64 bit. My Logitech wireless keyboard did not have a right windows key, but I also had a dell wired keyboard connected because of a glitch (and the c, h and v didn’t work there either) and tried the right windows key which then made it work. Very strange.

  20. Hi there,

    stefan from hannover germany here, please excuse my awful english :)
    i’m trainee in a bigger company, and same issue occurs to our users.

    1) i used your solutions posted here, the one that worked was double-tapping the right (super) windows key
    2) keys effected were c v and h
    3) occured in the IE9 with standard add-ins and a non-standard addin for spell-check
    4) out users are working at terminal-sessions on a windows 2008r2

  21. I had the EXACT same problem. Mine was on a Dell laptop, windows 8, in internet explorer, with the keys: c, h, v, and /. You said your key was “t” but yours being in a different operating system [xp] it kinda makes sense. Ok so my fixes were: Open a new tab worked for a few minutes then messed up again. The fix that has lasted the longest was Windows key twice really fast. Hope I helped at least one person!

  22. Had the same problem on new Acer Iconia W700 running W8 64b. It seemes as it is “Store” in W8 that triggeres the malfunction. Using ctrl+alt+del and closing all running apps, all worked all right again.

  23. Had this issue happening frequently when I use my wireless keyboard, but never once with the wired keyboard. Also, mine affects the system globally and can only be fixed by logging out and then back in again. Usually the lack of c v h sets in only after another problem where the Windows key self-activates and remains stuck (which leads to annoying issues like having the screen locked or the window closed when I’m in the middle of something). I think it’s pretty obviously related to the Windows key, though it might be worth noting that I run in Japanese locale (though I do not have the language or any of its shortcuts active). Also, once the Windows key issue or the c v h issue occurs, it causes Firefox to permanently stop accepting all keyboard input (until logging out or restarting).

  24. Thanks so much! I was having this problem with c, v, and h in Google Chrome. They would only work with the shift key. I double tapped the Windows Key and it was immediately back to normal!


    I double tapped fn + windows key and it fixed it. I did it again and they stopped working. It could be some sort of short cut to turn off the keys, I don’t know why they are made like this, but huzzah.

    1. That’s interesting. You are the first person to report being able to trigger it. I’m guessing that will not remain persistent after a reboot though. Let me know if you test further, Lukas. Not sure how this might translate for someone who has a non-laptop keyboard…

  26. I have Windows 7 on a HP EliteBook 8460w laptop. I was able to solve the problem by going into “Text Services and Languages” > Advanced Key Settings. There was a Key Sequence setting to switch between input languages. I must have pressed this sequence by accident to cause the problem. When I pressed it again (mine was Left Alt+Shift) the problem went away.

  27. I too just experienCed tHe loss of C, V, and H in lower Case as desCribed aboVe, but as you Can see, tHe letters type just fine in Caps! Quirky quirky….T works just fine. And tHanks for taking tHe Time to log tHis in tHe artiCle. I was otHerwise going to replaCe my keyboard. I tHink you Could title tHe artiCle, “HigH-teCH BleCH…” I am experienCing it on Windows 7 witH CHrome and Mozilla….

  28. I have an Acer laptop. I lost igoogle and went to Don’t know if that had anything to do with it but I have tried EVERYTHING and still cannot print c. I am using my desktop to send this. This has happened before and after a month just went away. Sooo frustrating, it happens everywhere, every website, email and on. There is no left windows key. HELP!

  29. I could solve the problem of keyboard not working with Fn + alt, but now I lost some of my keys – c,v,h,t,… :/

    Have to work with caps lock + shift key now.

  30. I just experienced the same problem as Gman. C,V and H would work fine upper case, nothing lower case. I was writing email in Outlook. When I tried to switch to Word, it would open a small Windows box in the upper right corner with a ‘Yes’ ‘No’ option. I didn’t think to write down the query.

    I unplugged my wireless keyboard from my HP Pavilion Elite HPE and plugged in a USB Dell keyboard. Problem was the same.

    I closed out Outlook and reopened it. The problem was gone.
    I appreciated seeing your article on this!

  31. I have a windows 8 laptop with a desktop usb keyboard plugged in and was RDP’d into a Windows 7 machine.
    The problem started when I disconnected from RDP and closed the lid on the laptop. Upon opening the lid I found that when RDP’d into my Windows 7 machine the “c” key would generate an error when typing in Outlook.
    Error Message was: “Outlook is unable to proceed with the reconversion”
    I could type the “c” key in several other applications but just not Outlook.
    Then I also noticed that I could not type the “h”, “v”, or “t” keys either but they did not throw the error message.
    After digging around and finding this blog, I removed the “Ink Correction” keyboard language and that resolved the issue.
    Having tried numerous key combinations before coming to this blog, I found that when I went to type in this comment box and found that the same combination of keys were not working (I was using the actual physical laptop running windows 8 to comment here). I tried removing desktop keyboard, double tapping the windows key on the laptop built-in keyboard. I finally plugged the desktop keyboard back in and single pressed the windows key on the desktop keyboard and I was able to type normally again.

    1. I’m afraid I’m a little confused. You say that removing “Ink Correction” “resolved the issue” but also that after “single press[ing] the windows key on the desktop keyboard … I was able to type normally again”. Why did you need two solutions? Did the first not actually work?

  32. I’ve been experiencing this problem in Windows 7 Home Premium, Service Pack 1, on a high end Alienware laptop. I frequently use windows-left/right shortcuts to dock windows to half-screen. Problem manifests seemingly randomly, c h v not working in certain applications. Thought I might have a virus or something. Thank you so much for this article! Fn key + Windows key fixed it. Seems like MS has a bug with the windows-left/right shortcuts.

    1. Well, it’s probably more than just those shortcuts since it’s been present in versions of Windows which don’t have those shortcuts, but if anyone is bothering to work on this bug this might be a useful clue. Thanks for offering your experience. Maybe someone at MS will one day care about this bug and read my blog!

  33. i might have useful information. i started hitting this problem a lot the last couple of days. i’m using a different machine than normal (netbook instead of desktop) and i see this when connected to a windows machine remotely. i’m not using ms rdp though, i’m using the so-called vrde server built in to virtualbox. windows is actually a local virtual machine.

    i use linux on all my systems and use the windows key + fN (win + f1, win + f2, etc) to switch between virtual desktops. i’ve long had the “stuck windows key” problem…i press windows key, then fN key to switch virtual desktops while the rdp connection to the windows VM is in focus — windows sees the key down but not key up and it’s stuck. recently with this machine though, i’m seeing this h, c, v keys not working crap. and it’s frustrating. pressing windows key brings up the start menu. another keypress and it goes away. no “stuck windows key” at all.

    on this laptop, i’m using function + win + fN to switch desktops. i can reproduce the problem pretty reliably; switch desktops enough times and it’ll happen. i can reliably fix it as well. with rdp in focus i start double-tapping function + win. sometimes it brings up the start menu and closes it again. i know it registered both taps, so no good. i keep doing that until only one is registered (start menu comes up but doesn’t close). the problem is now fixed and the keys work again. something eats that second function + win keypress and gets it working again.

  34. 1. The Windows 2x tap worked just fine (for now)
    2. h, c, and v, to my knowledge
    3. Chrome, Word, and possibly others, though not Notepad
    4. Windows 7

    Really weird occurrence- has never happened to me before. I’m worried about some sort of virus etc… paste and copy worked just fine for me as well. Thanks very much for this!

  35. I just had a similar experience. After disconnecting a bluetooth keyboard I was using, all of my keys seemed to default to keyboard shortcuts(without CTRL+ALT etc). so I did what any human male would to, and hit the keyboard. Suddenly a few buttions just stopped working. So I tried the “on screen keyboard, with a similar result. Since I was at my login screen and missing characters from my password I defaulted to the most proven repair method, a hard reboot. After the computer booted once more to my awe, all was well. I hope this helps anyone ever in a similar situation, although I would advising step two,(bashing the keyboard).

  36. Tis is a new one on me. Started today, working witH an HP Probook 4540s, Win7, and apparently te H works fine upperase, but no lowerase, same wit te CVH.
    Hae also got an odd situation wit te baCkspaCe key, were Hitting tHat turns off my wireless.
    THis is Happening in a few partiular programs (work-speCifiC). But in MSWord eVeryting seems to work fine. It Continues witH a USB-plug-in keyboard, too.
    First symptom tis morning was tat te downward arrow stopped working. Simple enoug to use te number 2 instead, but it was only te start of a messy day.

    OH and full disClosure, Had my first spill on tHe laptop yesterday, a Cup of Earl Grey Hot (no sugar, just water and tea). THe damage seemed to be minimal and tHe Cleanup was Very quiCk, but I Can’t Help but tHink tHat tHe spill and tHis new problem are related.

  37. thanks, had exact problem on chrome for the past couple of days,

    Fn key + left Windows key – is perfect solution…it basically, toggles between certain key functions which am not sure of…

  38. I had this problem after remoting into a troublesome Lenovo laptop. I double pressed the left windows key, then the right windows key, and the problem was fixed! I didn’t check to see if the left windows key fixed the problem, but definitely one of them (or both) fixed the problem.


  39. Windows 7… Has occurred randomly in single applications: Chrome, Outlook, Windows Start Menu, Notepad. Also didn’t register input from on-screen keyboard. Could still use shortcuts ctrl-c for copy etc….and I could type upper case letters. I could not type lower case c,h,t,v.

    Tapping left windows key twice or spamming it didn’t work: spammed right hand side windows key for an odd number of times and it fixed the issue.

  40. windows 8.1 –> and same problem here. “c” “v” and “h” not working on outlook 2013,…. glad to find this article, help me to resolve very fast, “double tap” on right windows key, and done :)


  41. My problem is similar but different in 2 significant ways:

    It is in Ubuntu 14.04 LTS, Trusty, 64 bit version, installed from the mini.iso using Openbox as window manager and desktop environment installed recently on a Toshiba Canvio 1 (so-called) “TB” usb-connected external hard drive. I honestly wonder about the drive because it has given me terrible problems booting and this isn’t the first time I’ve had problems with Toshiba drives.

    It’s also different characters. The “x” and several of the number keys are affected. It only started happening less than 24 hours ago so there may be other keys I haven’t found out about yet. The “1” is one of the keys affected. “4” is not affected. I’m a little hazy on the other number keys – I think maybe the other affected ones were 2, 0, and 9 but I can’t swear to it. I’ll write them down next time.

    The other aspects are more like the other posts here:
    Application specific – I’ve only seen it in Firefox 30.0. I pull up a text editor to type in when it happens and then copy and paste.
    Doesn’t matter whether I use the hardware keyboard (which is a cheap wireless) or an onscreen virtual keyboard worked by mouse – both are affected the same way.
    Intermittent. Often goes away if I close and restart Firefox. The first time it happened I had a lot of tabs open, but it’s happened since with only 2 or 3.
    AMD dual core cpu. 4 gig of RAM. Here’s my uname:

    $ uname -a
    Linux m 3.13.0-30-generic #54-Ubuntu SMP Mon Jun 9 22:45:01 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux

    I’ll try some of these workarounds next time it happens and let you know.

  42. I can amplify that now:
    These are the numbers that don’t work:
    0 1 2 6 9
    Lower case x and z don’t work.
    Upper case X and Z made with cap-lock don’t work.

    Upper case X and Z made with shift-key DO work.
    All letters and numbers work.

    Neither double tapping either super key or either control key helps, nor does copy and paste. Reloading the page doesn’t help. Shutting down firefox and restarting did, or at least it worked afterward. Of course I can’t completely rule out happenstance in that case, especially since sometimes in the past it DIDN’T work.

    I have an hypothesis I’m going to test:
    Some modifier key or keys is being acted on. Like right-cntrl shift for example. If that is the case, the fact that Onboard is affected doesn’t completely rule out a faulty keyboard. Firefox seems to have lots of poorly documented or downright undocumented * key codes. Which could be why this shows up so often in Firefox.

    *(maybe even UNINTENDED – my opinion of the competence of firefox and mozilla devs is pretty darned low right now – I keep hoping the Ice Weasel crowd will finally say “screw compatibility” and turn it into a full blown fork. Mozilla has become more arrogant than MS. Fork ’em I say)

  43. I’d be curious to know if any of you have error messages in your boot logs suggesting some irregularity in the system’s recognition of the keyboard or in interpretation of its keycodes. I’m not sure what that would look like on Windows. I’m getting:
    systemd-udevd[355]: Error calling EVIOCSKEYCODE: Invalid argument in dmesg, which if I understand it correctly suggests the the kernel doesn’t have all the information it needs to properly interpret all the signals from the keyboard. Which would fit with the idea the problem may originate with spurious control key (shift, alt, super, caplock, etc.) signals from the hardware keyboard, or signals that get incorrectly interpreted as control key signals.

      1. No, because I don’t have one handy. Good idea though. Pretty sure I’ve got some partially functional keyboard around here somewhere. Just gotta find it.
        /me wonders which pile to start looking in.

        Come to think of it, NO keyboard is worth trying, diagnosticly at least.
        Next time it happens I’ll try disconnecting the usb transciever for the keyboard and see if the virtual keyboard is still affected when it it the only one present.

        This seems to be happening 2 or 3 times a week so I should be able to report on that in a few days. Thanks for the thought.

  44. Wow – thanks for this page. I have had this problem intermittently over the last couple of months, and didn’t even want to begin to contact IT support for fear of sounding crazy :) So each time I’d just reboot.

    After reading these suggestions, what worked for me was double tapping the left windows key.

      1. Possible workaround to lack of a right Windows key…

        Background: I encountered this problem more than a year ago, and I too lack a right Windows key. As I mentioned at the time I eliminated the problem without rebooting, by connecting to my PC using MS Remote Desktop.

        Out of interest, I’ve searched on and off for a workaround for the lack of a right Windows key. I haven’t found a (free) on-screen keyboard that supports such a key, but today I came across the “sendkeypress” sub-command of NirSoft’s nircmd tool. It comes in several minor variants. I use nircmdc-x64.exe but it’s probably best to just use nircmd.exe.

        I’ve used this tool for years for command-line access to actions more normally done via a GUI, such as opening/closing cdrom trays, hibernating, etc. Today I learned that it can send keystrokes to Windows as if the user had actually typed the key. BTW there’s an online command reference.

        The fastest way to try it is to download nircmd.exe to say C:\tmp. Open a command prompt and type:

        cd /d c:\tmp
        nircmd sendkeypress rwin

        If you want a more general solution for unskilled users, you can use nircmd itself to create a program shortcut. As before, open a command prompt and type:

        cd /d c:\tmp
        nircmd cmdshortcut c:\tmp "Right Windows Key" qboxcomtop "Do you want to perform a keypress of the right Windows key?" "Right Windows Key" sendkeypress rwin

        This creates a shortcut named “Right Windows Key” in c:\tmp, that when invoked will run the command:

        C:\tmp\nircmd.exe qboxcomtop "Do you want to perform a keypress of the right Windows key?" "Right Windows Key" sendkeypress rwin

        To make things tidier you can right-click on the shortcut and change its Shortcut “Run” property from “Normal Window” to “Minimized”.

        I hope this helps someone.

Leave a Reply

Your email address will not be published. Required fields are marked *