Keyboard Input Ignored for c, h, t, and v Keys in Specific Applications Only

Every once in a great while I see this odd problem arise. I have not yet found a solution but when I do it will find a home here.

Basically what happens is I will hop over to a specific application, try to type into that application, and find that certain particular letters will do nothing. This time it was these four letters: t, h, c, and v, but I think that sounds like what it was on other occasions (though I don’t recall perfectly).

Most recently this happened in Outlook. I have seen this happen in Outlook before, but I’ve seen it happen a couple of times in Firefox and once in Opera. It is definitely not a keyboard problem, a driver issue, a problem with the specific application, or a keyboard shortcut issue—nor is it a virus or spyware.

Something as yet undetermined happens in the wonderful world of Windows XP (I have one user reporting this in the Mac OS as well) wherein those four letters are completely ignored as input. It only effects a single application when it occurs. No alt-, ctrl-, or windows- commands are executed when any of those keys are typed. I can press the same key, the t say, 100 times and absolutely nothing will happen. Then I switch to another application et voilà it works fine. For instance I’ve had to type an e-mail reply into a text editor and paste it into the reply window because I couldn’t type basic words like the.

Using associated keyboard shortcuts seems to be unaffected. As noted I was not able to type the letter v. However, I was able to use ctrl-v to paste into the reply window.

Now I know you’re going to think: “well it must be that reply window”.  Again, it’s application-wide.  I am not able to type those letters into the search boxes or contacts windows or any other place that might allow text entry—within the afflicted application.

Also, I have seen this on at least three machines where there can be no relation between them (except my smiling face reflected in the monitor).  I think I have seen this happen maybe half a dozen times in the last couple of years.

It’s easy enough to fix by restarting the afflicted application, but I am on the path for this one.  It’s stuck in my craw so I won’t be satisfied until I figure what the hell is going on.

It has come to my attention this may also effect on-screen keyboards.  Please test this in your case if you are able, and let us know your results below.

I’ll try to keep this up to date concerning my progress, but feel free to share your solutions. I’m all eyes.  (This happens rarely enough that it’s good to have others contributing data.)

(It will be useful to include four items in your comments: 1) your solution (even if temporary); 2) keys effected; 3) application(s) effected; and 4) operating system(s) involved.)

Random Solutions and Workarounds Culled from the Comments (and Elsewhere):

(In no particular order.  This may not be complete and up-to-date.)

  1. A double-tap of the Windows (or Super) key.
  2. A double-tap of specifically the right Windows key.
  3. Restart the effected application (or Explorer if effected)
  4. Reboot (last resort).
  5. “Detect and Repair” from the Help menu in Outlook (Outlook only)
  6. Press CapsLock and Shift back down to lower case (this is a per letter fix)
  7. Fn key + Windows key may toggle problem on and off.
  8. Alt key + Windows key may toggle problem on and off (especially in Win8).
  9. Region and Language —> Keyboards and Languages —> change keyboards;
    delete all keyboards other than your language and delete all instances of “Ink Correction”.  Or try changing the format setting at Format (dropdown): from English (United States) to English (United Kingdom) and click OK.
  10. Disable Sticky Keys (Control Panel —> Ease of Access Center —> Make the keyboard easier to use —> Make it easier to type —> uncheck “Turn on Sticky Keys“)
  11. Remove all keyboards from the Device Manager and reboot.
  12. Login to the effected machine via RDP and then return to the machine and login locally.
  13. Laptops may have to use the Widows key on the laptop and not a secondary keyboard.
  14. In Win7 it may be useful to check for keyboard/language changing hotkeys here Control Panel —> Region and Language —> Keyboards and Languages —> Change Keyboards —> Advanced Key Settings
  15. If you have only a left Windows key, you may attach an external keyboard which does.  Failing that, user Matan below wrote a right-Windows-key simulator which can be found here.  (Please note that I cannot guarantee the integrity of that source, so please use appropriate caution when downloading from unknown sources.)
  16. User Klode as offered another possible solution for users lacking a right-Windows key.  Open a command prompt and type first cd /d c:\tmp (then press Enter) followed by nircmd sendkeypress rwin (and press Enter).  Klode also describes how to create a shortcut for that and his comment can be found here.

If none of these work or if you have one to add yourself, comment away.

(It will be useful to include four items in your comments: 1) your solution (even if temporary); 2) keys effected; 3) application(s) effected; and 4) operating system(s) involved.)


604 thoughts on “Keyboard Input Ignored for c, h, t, and v Keys in Specific Applications Only

  1. THANK YOU for this post! I now have a way to fix my problem without having to restart my computer all the time! Alt + Windows Key worked for me.

    1. Wow, how the hell did you work that one out!

      I just replaced my dell laptop keyboard and was more than dismayed that a few keys still didnt work.

      But you’re suggestion worked.


    1. Melle – You may attempt some of the fixes offered in the solutions list. The Command key (the Apple key) is the same as a Windows key. I’m not sure how many of the others may have a parallel on the Mac. Let us know about your situation. Hope it helps.

  2. I thought I was going crazy! Thank you!

    Deleting the “Ink Correction” instance from Control Panel > Region and Language > Keyboards and Languages got it working for me (Windows 7 x64)

  3. As I was working on my dissertation on Microsoft Word and wanted to write the word precisely, I was unable to type the letter C as the little warning box showed up and said word unable to convert please select some of the text and reconvert (something like that. can’t remember the exact sentence). So I found this article and I immediately double tab my window button and word could type the letter C again… so thanks a lot for this article. It saves my life :)

  4. In Microsoft outlook 2010 I have been facing issue when sending email, replying or forwarding and typing keys are not working c, h, t, and v Keys. But same time same keys are working in Microsoft Word and other Microsoft applications. But specifically it is not working in Outlook express. I need to restart my computer and middle of the work I have to save all my applications. Please provide appropriate solutions for the same.

    Keyur Vaidya

    1. Keyur – Outlook Express? Are you still running Windows XP? Have you considered installing Ubuntu as your operating system and moving to Libre Office? All of the solutions listed at the bottom of the original post should be tried.

  5. Thank you for this post!
    I see this daily whilst running Windows 8.1 Pro, I thought it was something to do with RDP sessions. Alt + Windows seems to cure it for me. The Caps lock + Shift allows me to enter the key once before I have to try again…
    Weird huh?

    (I am using an HP ProBook 6570b in the dock with a USB keyboard – the keys are effected on both the external keyboard and the laptop one, usually closing the effected app & launching again resolves the issue)

    1. It depends on your machine, Tony. Many keyboards have a light to indicate capslock, though not all. Same for laptop keyboards. You really just have to know for your machine. Though you could easily open Notepad (or another simple application) and determine whether it were on or off by typing something.

  6. I am having trouble with c, t, ., i, 3 and 7.
    I have just re-installed Windows 8.1 which didn’t fix it.
    Neither do any of the solutions you listed that I could do on Windows 8.1

    I would greatly appreciate any other fixes you might have.

    1. Stephen – If it has persisted across a rebuild, it cannot be a software issue. I would test booting into any live CD (Ubuntu, Clonezilla, GParted, anything) and see if you still have that keyboard issue. If it persists across a clean installation it really must be hardware. Well, I suppose Win8.1 could be using the wrong keyboard driver. But most likely hardware. Anyway, you’ll know if you see the same trouble in a live CD.

  7. I have managed to get my keyboard to work by selecting the left windows button and the fn key but after a while, the keyboard failed to work again. This is getting pretty annoying.

    I’m having issues with the following letters “t” “y” “o” “tab” and now the windows button.

  8. This may be interesting for your further research.

    While the problem was in place and I could not user the lowercase c, v, and h keys, I opened the Task-Manager, and there all keys were working properly! (Just try to press “c” while in the process list to jump to a process, which name starts with “c” to try it out.)

    So basically the problem seemed to be only for the other windows, but not system windows as the Task Manager.

    I closed all applications, but only after closing the last app (Google Chrome Browser) the problem was gone. So I think, If not Chrome alone is causing the issue, probably it is some communications problem between different it and some other apps.

    Does anyone have experienced this issue NOT having Google Chrome installed on the computer?

    1. Adriano – I don’t necessarily install Chrome on my machines (I use Opera). This aspect may be unique to your situation. I would try using Revo Uninstaller to completely remove Chrome and re-install it. See if that effects things.

  9. Double tap of the right Windows button worked for me (I hadn’t even noticed that existed). But does anyone know why this happens?
    Happens to me on 10 and my colleague on 7.

  10. Hi there.

    I had this problem on my Toshiba Satellite laptop. For a long time on Windows 10. What I did to fix? Actually no single thing mentioned here helped me. I did today two things and one of them fixed problem.

    1. I was visiting the app (preinstalled) Toshiba System Settings. Then Keyboard section from menu. Here I changed F1-F12 advanced mode to F1-F12 normal mode.

    2. I was going to preinstalled app Toshiba Service Station and checked updates and updated what requested.

    Now I am on laptop for 30 minutes and no single writing problem and also CTRL+V etc. works. Before I had problem especially with r, g, and n. And CTRL C&V. It seems to work after these two, at least before I had problems almost every few minutes. Sometimes I was pressing long time, even many times in row, before letter appeared. Now it just works.

    If you have Toshiba laptop, this might help. I will report back if this stands as it is now.

  11. Deleting the ink corrections portion out of the settings cured all my problems, whoever thought of putting that in the settings for a keyboard needs to be flogged with an anchor chain.

  12. So it started to happen again and I sent it to repair with my shop from where I purchased it. It is here about for month and I got a laptop what to use when mine is in repair. It is another brand of Toshiba with 8.1 and I updated it to 10, and no this problem. So mine was almost like hardware issue. I will return this laptop when I receive mine from warranty. It seemed to work sometimes and sometimes not.

  13. My Surface Pro was not letting me type the “c” and “h” key. I switched keyboards, and the problem persisted. The problem went away when I rebooted; so I looked up this article.

    I’ll definitely print the workarounds from this article!

  14. My laptop is now repaired and I will receive it next week back.

    So maybe everyone should consider about repair within warranty.

    They ordered some kind of component, so something were broken in keyboard or somewhere.

  15. My laptop is now back in business. They replaced keyboard and touchpad – now all works. So don’t waste your time with dealing settings. The problem might be in components itself. Now I can write perfectly. Regards and christmas to this blog creator.

    1. Most of the time it really is a software issue. I’ve seen this many times persist between different keyboards (for example a laptop where one can attach a USB keyboard and still see the same behavior). Glad yours was fixed for you though.

  16. Had this happen to me on Windows 10 Pro x64 last night and this morning. To make things even more exciting, Windows decided it should disable my ‘h’ key at the login screen, and my login password had an ‘h’ in it.

    I tried the Alt-Windows Key trick. First I tried the left alt-windows key, nothing. Then the right, which seemed to work.

    I’ve scoured Google and haven’t been able to determine a root cause, although I did find folks reporting a lot of strange keyboard behavior after messing with the accessibility features. I had disabled sticky keys and had tinkered with these settings a couple of days ago. I don’t remember what I selected/deselected, but I did notice that Windows had enabled accessibility options on the login screen, shown in the bottom right of the screen. This wasn’t there before. I also noticed an “eye” icon in the password field that had never been there. When clicked, it shows the password you are typing in as opposed to the dots. *shrugs*

  17. Thank you! I’ve been having this problem quite a bit – I’m on Windows 8.1, it’s only been afflicting Skype, restarting Skype fixed it but given it doesn’t save my settings and tries to get me to update (I’m using v6.21 because v7+ is terrible) it’s NOT optimal – and fn+windows key has fixed it! It’s been happening consistently for c/h/v, but t hasn’t been affected. I do not comprehend, but it works, thanks!

  18. Thanks for this! The ctrl/shift combo worked for me. To add to your knowledge base:
    OS: Server 2012r2
    Mode of connecting: idrac6
    This was a newly image server, nothing had been done to it yet.
    What may be helpful to note: while I could type letters p and u, they launched other functionalities. P would try to connect to a projector, so it may be that another key was detected as being active (eg function key.)
    Anyhow, thanks for the help!

  19. Hi,
    Whenever I try to copy and paste some info I get sent through a special portal, into Google translate it appears without the letter ‘c’. It also does not appear when I just try to paste into word – losing my hair having to replace every missing ‘c’!
    Any ideas would be great – thanks very much.

    OMG, it doesn’t even work when I try to paste it into here :(
    Here’s the text:
    h freue mi
    h, Ihnen dieses Stellenangebot übermitteln zu können. Bewerben Sie si
    h bitte
    umgehend, so wie im Inserat bes
    Führt Ihre Bewerbung zu einem Vorstellungsgesprä
    h, nehmen Sie bitte dieses S
    hreiben mit
    und ersu
    hen das Unternehmen, im unteren Abs
    hnitt das Ergebnis einzutragen.
    Bitte informieren Sie uns, wie vereinbart, innerhalb von 8 Tagen über das Ergebnis bzw. den
    Stand Ihrer Bewerbung.
    Sollte dieses Stellenangebot unseren Vereinbarungen oder Ihren Qualifikationen ni
    hen, kontaktieren Sie uns bitte sofort.
    Für Ihre Rü
    kmeldung oder bei allfälligen Fragen nutzen Sie Ihr eAMS-Konto bzw. steht Ihnen
    unsere Servi
    eLine unter der Telefonnummer (01) 87871 gerne zur Verfügung.
    Viel Erfolg bei Ihrer Bewerbung!

  20. Awesome, don’t even know how to thank you….
    my zs and /s werent working so that really affected my short cuts.

    Why it worked i don’t know…but its awesome thanks again.

  21. Thank you for this solution. Today this problem happened twice in VS2010. I’ve never seen this before in over twenty years using VS. Tapping the left Windows twice fixed it :-)

  22. In my case, 4 keys don’t work. c, v, h, /
    I suspect chrome browser and microsoft excel 2016 do something.
    for many cases, when this happens, these two applications are running.
    shift + c works(capital C can be typed) but CapsLock and c doesn’t.
    even if I connect another keyboard, it also doesn’t work for 4 keys.
    when it happens, some other applications also refuses these 4 keys, for example, I cannot type c, v, h, / onto windows run command windows(Windows + R shortcut)
    my workaround is restart these apps or reboot.
    any other workarounds you mentioned does not work for me.
    my OS is windows 10 home.

  23. I have just had this problem using the Outlook Web App, affecting C,V and H keys. I couldn’t type them into a message, in the search bar etc, but switch to a different application or a different tab in my browser and everything is fine!

    I was halfway through reading your post and you wanted to know if it affected on-screen keyboards too, so I opened up my on-screen keyboard, went back to OWA, and the letters were working, with both the on-screen and physical keyboards. How strange!

    Anyway, thanks for your post, this isn’t the first time it’s happened to me, and although it’s amusing it’s also slightly irritating! :-)

    I’m using Windows 7 on a Dell Vostro laptop and at the time was running Outlook Web App in Internet Explorer.

      1. I’ve been experiencing what must be the same or closely related issue with Quicken. Pressing ALT+TAB while Quicken’s account register is open triggers the bug 100% of the time. After that the lowercase a, c, d, g, s, t, and z keys don’t work. A double tap of the windows key is sufficient to correct the issue.

        Thanks for the double tap ‘fix’ – it is much easier than restarting Quicken.

  24. I just double tapped my left windows button after going through your suggestion and its working now…..Thank You so much for helping with the information. It was damned annoying to type without v, c, h and back space was not working in hangouts and whatsapp in my chrome.

  25. I am so happy that the right windows key thing finally worked!!!
    My laptop kept having issues with the windows key clicking itself, so when I typed something like “electric,” it could glitch out and open Windows Explorer (WINKEY + e), Settings (WINKEY + i), or lock the computer (WINKEY + l). It’s a laptop so it only has the Left Windows Key, but after the nircmd fix, I think that there’s a “ghost” right windows key that keeps getting held down.

    Of course, I did drop my laptop from the table a few days ago, so that might have some influence…

  26. Thank you for this blog! My h went crazy while working in the microsoft word application. It would only type at all when I hit the shift key; then only type in small case when I hit the shift key with the caps lock on and only type in caps when I hit the shift key with the caps lock off! Maddening! But I hit the windows key twice and it started working correctly again. I have a Dell Inspiron 17 Windows 10. Wow! Thanks again!

  27. Happens to me sometimes, more often lately. Got macbook air. No solution so far but problem disappears after a while, I think after pressing other keys a few times that actually work. Mostly the letters e, t, y, u, i stop working that I can think of now. But also others. Very strange. Very.

  28. I had something like this on my father’s windows 10 machine. It turned out to be Skype. It was intercepting the letter p, thinking it was the mute command.

    Who thought using a single letter key press as a hotkey was a clever idea????

  29. Thanks so much! This has been happening to me the past few days out of the blue, specifically on Opera 42.0. As far as i know it hadn’t been updated. I couldn’t type with the on screen keyboard either but it worked everywhere else. A quick double tap of the right windows key did the trick. I wonder what is causing this weird issue!?

  30. I downloaded an in game chat engine for League of Legends called Curse and that is when the problem started for me. I uninstalled the program and it went away… just another possiblity.

  31. With no hope I went into your website.. and the second fix worked! Its incredible how an article written 2 years ago provided such information. Thanks a lot!

  32. Wonderful Solution James!!!

    Thank You… Fn+Win worked for me for MS Word…

    Kindly update on this post whenever you find about the root cause of this issue.

    1. Morgan — I have not see this as a bug in a Mac as yet. It may be that one of the published solutions in the article will inspire a related solution for your Mac issue, but you will definitely what to try a different keyboard to ensure it is not a hardware problem. If it only takes place in the terminal, that’s rather odd indeed. Let us know if there are any other interesting details to this case.

  33. Hi! I’m still using Windows 7 professional and have recently encountered an issue with the input of some keys not registering… sometimes. Very hit and miss, but every word would have some letter missing; typically e, n, t and the space bar. I figured it was the age of the keyboard (and the fact that coffee was spilled on it a year ago). After replacing the keyboard, I found the problem was still there, but only in Microsoft Word. The problem did not affect any other Microsoft program. What finally worked was disabling an add-on in Word; specifically Snag-it. Thanks so much for the suggestions!

Leave a Reply

Your email address will not be published. Required fields are marked *