Keyboard Input Ignored for c, h, t, and v Keys in Specific Applications Only

Every once in a great while I see this odd problem arise. I have not yet found a solution but when I do it will find a home here.

Basically what happens is I will hop over to a specific application, try to type into that application, and find that certain particular letters will do nothing. This time it was these four letters: t, h, c, and v, but I think that sounds like what it was on other occasions (though I don’t recall perfectly).

Most recently this happened in Outlook. I have seen this happen in Outlook before, but I’ve seen it happen a couple of times in Firefox and once in Opera. It is definitely not a keyboard problem, a driver issue, a problem with the specific application, or a keyboard shortcut issue—nor is it a virus or spyware.

Something as yet undetermined happens in the wonderful world of Windows XP (I have one user reporting this in the Mac OS as well) wherein those four letters are completely ignored as input. It only effects a single application when it occurs. No alt-, ctrl-, or windows- commands are executed when any of those keys are typed. I can press the same key, the t say, 100 times and absolutely nothing will happen. Then I switch to another application et voilà it works fine. For instance I’ve had to type an e-mail reply into a text editor and paste it into the reply window because I couldn’t type basic words like the.

Using associated keyboard shortcuts seems to be unaffected. As noted I was not able to type the letter v. However, I was able to use ctrl-v to paste into the reply window.

Now I know you’re going to think: “well it must be that reply window”.  Again, it’s application-wide.  I am not able to type those letters into the search boxes or contacts windows or any other place that might allow text entry—within the afflicted application.

Also, I have seen this on at least three machines where there can be no relation between them (except my smiling face reflected in the monitor).  I think I have seen this happen maybe half a dozen times in the last couple of years.

It’s easy enough to fix by restarting the afflicted application, but I am on the path for this one.  It’s stuck in my craw so I won’t be satisfied until I figure what the hell is going on.

It has come to my attention this may also effect on-screen keyboards.  Please test this in your case if you are able, and let us know your results below.

I’ll try to keep this up to date concerning my progress, but feel free to share your solutions. I’m all eyes.  (This happens rarely enough that it’s good to have others contributing data.)

(It will be useful to include four items in your comments: 1) your solution (even if temporary); 2) keys effected; 3) application(s) effected; and 4) operating system(s) involved.)

Random Solutions and Workarounds Culled from the Comments (and Elsewhere):

(In no particular order.  This may not be complete and up-to-date.)

  1. A double-tap of the Windows (or Super) key.
  2. A double-tap of specifically the right Windows key.
  3. Restart the effected application (or Explorer if effected)
  4. Reboot (last resort).
  5. “Detect and Repair” from the Help menu in Outlook (Outlook only)
  6. Press CapsLock and Shift back down to lower case (this is a per letter fix)
  7. Fn key + Windows key may toggle problem on and off.
  8. Alt key + Windows key may toggle problem on and off (especially in Win8).
  9. Region and Language —> Keyboards and Languages —> change keyboards;
    delete all keyboards other than your language and delete all instances of “Ink Correction”.  Or try changing the format setting at Format (dropdown): from English (United States) to English (United Kingdom) and click OK.
  10. Disable Sticky Keys (Control Panel —> Ease of Access Center —> Make the keyboard easier to use —> Make it easier to type —> uncheck “Turn on Sticky Keys“)
  11. Remove all keyboards from the Device Manager and reboot.
  12. Login to the effected machine via RDP and then return to the machine and login locally.
  13. Laptops may have to use the Widows key on the laptop and not a secondary keyboard.
  14. In Win7 it may be useful to check for keyboard/language changing hotkeys here Control Panel —> Region and Language —> Keyboards and Languages —> Change Keyboards —> Advanced Key Settings
  15. If you have only a left Windows key, you may attach an external keyboard which does.  Failing that, user Matan below wrote a right-Windows-key simulator which can be found here.  (Please note that I cannot guarantee the integrity of that source, so please use appropriate caution when downloading from unknown sources.)
  16. User Klode as offered another possible solution for users lacking a right-Windows key.  Open a command prompt and type first cd /d c:\tmp (then press Enter) followed by nircmd sendkeypress rwin (and press Enter).  Klode also describes how to create a shortcut for that and his comment can be found here.

If none of these work or if you have one to add yourself, comment away.

(It will be useful to include four items in your comments: 1) your solution (even if temporary); 2) keys effected; 3) application(s) effected; and 4) operating system(s) involved.)


489 thoughts on “Keyboard Input Ignored for c, h, t, and v Keys in Specific Applications Only

  1. THANK YOU for this post! I now have a way to fix my problem without having to restart my computer all the time! Alt + Windows Key worked for me.

    1. Melle – You may attempt some of the fixes offered in the solutions list. The Command key (the Apple key) is the same as a Windows key. I’m not sure how many of the others may have a parallel on the Mac. Let us know about your situation. Hope it helps.

  2. I thought I was going crazy! Thank you!

    Deleting the “Ink Correction” instance from Control Panel > Region and Language > Keyboards and Languages got it working for me (Windows 7 x64)

  3. As I was working on my dissertation on Microsoft Word and wanted to write the word precisely, I was unable to type the letter C as the little warning box showed up and said word unable to convert please select some of the text and reconvert (something like that. can’t remember the exact sentence). So I found this article and I immediately double tab my window button and word could type the letter C again… so thanks a lot for this article. It saves my life :)

  4. In Microsoft outlook 2010 I have been facing issue when sending email, replying or forwarding and typing keys are not working c, h, t, and v Keys. But same time same keys are working in Microsoft Word and other Microsoft applications. But specifically it is not working in Outlook express. I need to restart my computer and middle of the work I have to save all my applications. Please provide appropriate solutions for the same.

    Keyur Vaidya

    1. Keyur – Outlook Express? Are you still running Windows XP? Have you considered installing Ubuntu as your operating system and moving to Libre Office? All of the solutions listed at the bottom of the original post should be tried.

  5. Thank you for this post!
    I see this daily whilst running Windows 8.1 Pro, I thought it was something to do with RDP sessions. Alt + Windows seems to cure it for me. The Caps lock + Shift allows me to enter the key once before I have to try again…
    Weird huh?

    (I am using an HP ProBook 6570b in the dock with a USB keyboard – the keys are effected on both the external keyboard and the laptop one, usually closing the effected app & launching again resolves the issue)

    1. It depends on your machine, Tony. Many keyboards have a light to indicate capslock, though not all. Same for laptop keyboards. You really just have to know for your machine. Though you could easily open Notepad (or another simple application) and determine whether it were on or off by typing something.

  6. I am having trouble with c, t, ., i, 3 and 7.
    I have just re-installed Windows 8.1 which didn’t fix it.
    Neither do any of the solutions you listed that I could do on Windows 8.1

    I would greatly appreciate any other fixes you might have.

    1. Stephen – If it has persisted across a rebuild, it cannot be a software issue. I would test booting into any live CD (Ubuntu, Clonezilla, GParted, anything) and see if you still have that keyboard issue. If it persists across a clean installation it really must be hardware. Well, I suppose Win8.1 could be using the wrong keyboard driver. But most likely hardware. Anyway, you’ll know if you see the same trouble in a live CD.

  7. I have managed to get my keyboard to work by selecting the left windows button and the fn key but after a while, the keyboard failed to work again. This is getting pretty annoying.

    I’m having issues with the following letters “t” “y” “o” “tab” and now the windows button.

  8. This may be interesting for your further research.

    While the problem was in place and I could not user the lowercase c, v, and h keys, I opened the Task-Manager, and there all keys were working properly! (Just try to press “c” while in the process list to jump to a process, which name starts with “c” to try it out.)

    So basically the problem seemed to be only for the other windows, but not system windows as the Task Manager.

    I closed all applications, but only after closing the last app (Google Chrome Browser) the problem was gone. So I think, If not Chrome alone is causing the issue, probably it is some communications problem between different it and some other apps.

    Does anyone have experienced this issue NOT having Google Chrome installed on the computer?

    1. Adriano – I don’t necessarily install Chrome on my machines (I use Opera). This aspect may be unique to your situation. I would try using Revo Uninstaller to completely remove Chrome and re-install it. See if that effects things.

Leave a Reply

Your email address will not be published. Required fields are marked *

You may use these HTML tags and attributes: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>