Keyboard Input Ignored for c, h, t, and v Keys in Specific Applications Only

Every once in a great while I see this odd problem arise. I have not yet found a solution but when I do it will find a home here.

Basically what happens is I will hop over to a specific application, try to type into that application, and find that certain particular letters will do nothing. This time it was these four letters: t, h, c, and v, but I think that sounds like what it was on other occasions (though I don’t recall perfectly).

Most recently this happened in Outlook. I have seen this happen in Outlook before, but I’ve seen it happen a couple of times in Firefox and once in Opera. It is definitely not a keyboard problem, a driver issue, a problem with the specific application, or a keyboard shortcut issue—nor is it a virus or spyware.

Something as yet undetermined happens in the wonderful world of Windows XP (I have one user reporting this in the Mac OS as well) wherein those four letters are completely ignored as input. It only effects a single application when it occurs. No alt-, ctrl-, or windows- commands are executed when any of those keys are typed. I can press the same key, the t say, 100 times and absolutely nothing will happen. Then I switch to another application et voilà it works fine. For instance I’ve had to type an e-mail reply into a text editor and paste it into the reply window because I couldn’t type basic words like the.

Using associated keyboard shortcuts seems to be unaffected. As noted I was not able to type the letter v. However, I was able to use ctrl-v to paste into the reply window.

Now I know you’re going to think: “well it must be that reply window”.  Again, it’s application-wide.  I am not able to type those letters into the search boxes or contacts windows or any other place that might allow text entry—within the afflicted application.

Also, I have seen this on at least three machines where there can be no relation between them (except my smiling face reflected in the monitor).  I think I have seen this happen maybe half a dozen times in the last couple of years.

It’s easy enough to fix by restarting the afflicted application, but I am on the path for this one.  It’s stuck in my craw so I won’t be satisfied until I figure what the hell is going on.

It has come to my attention this may also effect on-screen keyboards.  Please test this in your case if you are able, and let us know your results below.

I’ll try to keep this up to date concerning my progress, but feel free to share your solutions. I’m all eyes.  (This happens rarely enough that it’s good to have others contributing data.)

(It will be useful to include four items in your comments: 1) your solution (even if temporary); 2) keys effected; 3) application(s) effected; and 4) operating system(s) involved.)

Random Solutions and Workarounds Culled from the Comments (and Elsewhere):

(In no particular order.  This may not be complete and up-to-date.)

  1. A double-tap of the Windows (or Super) key.
  2. A double-tap of specifically the right Windows key.
  3. Restart the effected application (or Explorer if effected)
  4. Reboot (last resort).
  5. “Detect and Repair” from the Help menu in Outlook (Outlook only)
  6. Press CapsLock and Shift back down to lower case (this is a per letter fix)
  7. Fn key + Windows key may toggle problem on and off.
  8. Alt key + Windows key may toggle problem on and off (especially in Win8).
  9. Region and Language —> Keyboards and Languages —> change keyboards;
    delete all keyboards other than your language and delete all instances of “Ink Correction”.  Or try changing the format setting at Format (dropdown): from English (United States) to English (United Kingdom) and click OK.
  10. Disable Sticky Keys (Control Panel —> Ease of Access Center —> Make the keyboard easier to use —> Make it easier to type —> uncheck “Turn on Sticky Keys“)
  11. Remove all keyboards from the Device Manager and reboot.
  12. Login to the effected machine via RDP and then return to the machine and login locally.
  13. Laptops may have to use the Widows key on the laptop and not a secondary keyboard.
  14. In Win7 it may be useful to check for keyboard/language changing hotkeys here Control Panel —> Region and Language —> Keyboards and Languages —> Change Keyboards —> Advanced Key Settings
  15. If you have only a left Windows key, you may attach an external keyboard which does.  Failing that, user Matan below wrote a right-Windows-key simulator which can be found here.  (Please note that I cannot guarantee the integrity of that source, so please use appropriate caution when downloading from unknown sources.)
  16. User Klode as offered another possible solution for users lacking a right-Windows key.  Open a command prompt and type first cd /d c:\tmp (then press Enter) followed by nircmd sendkeypress rwin (and press Enter).  Klode also describes how to create a shortcut for that and his comment can be found here.

If none of these work or if you have one to add yourself, comment away.

(It will be useful to include four items in your comments: 1) your solution (even if temporary); 2) keys effected; 3) application(s) effected; and 4) operating system(s) involved.)


602 thoughts on “Keyboard Input Ignored for c, h, t, and v Keys in Specific Applications Only

  1. I am an 8 year old irl, and I ave some problems… u can clearly see te G word was not poppin up correctly… Clearly I cannot fix tat. I can only copy and paste te G words by copying.. It would take muc less time… even te word after g I ave problems!
    please elp…

    1. Jenna – All of the possible solutions and workarounds I have collected are located at the end of the post. If you read through to the end of the post I trust you will find one that will work for you.

  2. All your comments seem to relate to PCs, but I am getting them also, but on my Apple Mac. I currently cannot type c or h when in Chrome / Google Mail, or Facebook (the only applications I have tried). But I have no problem in Word, so I am typing messages in Word and then cut and pasting them into the Mail text box. Doesn’t help with control keys though.

    As I am Apple, any suggestions what to use instead of the (absent) Windows key?


    1. Terry – I have not seen this happen on a Mac. (I work with them every day as my employer runs about 65% Mac.) If you discover anything interesting, please report back.

      Are you perhaps running Bootcamp Windows?

      Incidentally, the Windows key is sometimes referred to as the Super key. This is because only Microsoft branded keyboards (or those appropriately licensed) may use the Windows symbol. Apple uses a similar symbol for their Super key (which they call the Command key and which used to be called the Apple key and then had an Apple logo). You might try that key.

      1. i have encounter this problem recently i can’t type “a” “g” “s” “u” but only on the comments in facebook. Its really weird, i thought someone hack me, so i tried to test it in other site google mail, yahoo mail, tweeter. But its only appear at comment on facebook.

        Solution: if your using chrome Unpin from tab and close (x) then create new tab and open facebook, then back to normal.


  3. SOLVED: after a long fighting it has been solved by changing the laptop keyboard!
    At the beginning it was clear to me that the problem popped up only when charging the battery and the laptop was warming up. But then it was worst and worst, till to stop working also the external USB keyboard!
    After changing the internal keyboard it never popped up anymore!
    Maybe its controller was over…

  4. OMG. I tapped left win key, nothing, i tapped right one and it started working again….U my friend are a life saver… ps. hate to reboot for stupid bugs :)

  5. I had this problem is well. It seemed to manifest after several RDP sessions using Logmein. It would seem to show up in random applications on Windows 7 64 bit. I found this page and tried the solutions. Killing the app worked, but was annoying. Rebooting also works (as it kills the apps). None of the Windows key solutions worked for me; however, I just stumbled on something. I have a ‘menu’ key next to my right windows key. I double tapped that and the problem magically went away. I think there is some confusion between RDP clients and certain key combinations that inadvertently trigger the menu mode or something. At any rate, double tapping the menu key fixed the issue for me.

    1. Yeah, several users have reported relations to remote sessions. I haven’t found a definitive way to reproduce the bug unfortunately. Let me know if you discover something consistent.

      Do you know what your Menu key does? I’m not familiar with that key.

  6. Do you know why I became crazy?
    Because in my keyboard I don’t have right windows key!
    So after a very long search in the web, I made a program that emulates right windows key double-tap. After that everything works just fine :)

    I’ve used InputSimulator API.

    My program.

    I think it will really help to anyone like me that doesn’t have that windows key…
    Have fun with it!

    1. BTW – Right windows key and left windows keys do not have the same Key Code, so it reasonably that pressing the left windows key won’t help the situation.

      Another thing, can someone check my program in windows versions other than windows 7? Thanks!

    2. Matan – Thanks for your contribution. I hope that does help others. And yes, I suspected they were different key codes since they behaved differently depending on the situation. Thanks for the confirmation.

      Please note, everyone else: I am not responsible for that which lies at the other end of those links.

  7. Fn + Windows key fixed it.
    Affected h and c… possibly others but only noticed those ones.
    Applications – start menu search and other random boxes
    Windows 7.

    1. Wow, Fn+Windows key worked for me too – thanks! It affected the c, h and v characters (but not the t) and had been doing it for years very, very occasionally on both Windows XP and Windows 8.1 on this laptop. It seemed to do it infrequently when I opened or did something involving Outlook, although I think from memory it would also do it with Chrome as well sometimes, even if Outlook wasn’t opened (I rarely use Outlook). Those keys affected worked alright with SHIFT though, and they even worked normally as lowercase in a DOS/cmd window, and they would work normally after a reboot. Toshiba Equim P200-178 laptop in case anyone’s looking for a trend.

    2. fn + windows key fixed it…
      I couldn’t type AT ALL in firefox and if I opened search (windows key + S) I couldn’t type c, h or v…
      Thanks very much to JamesIsIn for posting this!

  8. I encounter different issue.
    the t cannot be type on Web edition of Office Communicator
    1. Log on my Office Communicator on IE11/Win 7.
    2. The laptop is Think Pad W530.

    this issue do not happen before. some day, we replace the url of OC. this issue comes.

    There is no right window key on my laptop.

    1. I don’t know that these solutions are the right ones unless the issue of ill-working keys if effecting your entire browser (and not merely one Web site). Nonetheless, you can either attach an external keyboard or try the most recent workaround posted at the end of the article.

      1. A friend of mine reported the same problem, with ‘h’ and ‘c’ keys only. I will definitely try the suggestions provided here, but before that, just wanted to confirm that using a USB keyboard did not resolve the problem. The same keys did not work on the USB keyboard, too.

        Pressing Shift-h did work. For now, I told my friend to toggle the CAPS Lock before pressing Shift-h according to his requirement.

    2. I ran into the same situation as ngwuedag and none of the other “fixes” worked. I did find a way to get it to work. When at the login screen for Office Communicator Web Access, click “Tools”, “Compatibility View Settings” and then click “Add”. This will add the domain that your Office Communicator is associated with and will run the chat screens in compatibility view and the “t” will be recognized.

      Good luck! Hope this works for you too.

  9. THANK YOU FOR THIS! almost this exact problem started with me yesterday and i thought i had lost my mind! why did the entire keyboard work except for ‘c, v, and h’??? I wasn’t sure how to find the answer, but your page popped up in my google search results and the very first answer fixed me! (double tap of the windows button)


  10. Thanks for the solution, the first one, double tap (or press) windows key works like magic!
    The keys c, h, v weren’t working for me (‘t’ works though) in Chrome. (only tried command prompt and notepad++ and they worked). I’m using win7 64bit. Super weird issue isn’t it!

  11. Yep, just had this issue with Windows 7 Pro SP1; no problem in Chrome, but only in MS Outlook (c, h, v – keystrokes not being received as letters; but pressing them twice seems to jump me to an Outlook help dialog suggesting that I am attempting to perform some sort of conversion? ).

    Problem disappeared when I double-pressed Windows key (I have only one, on the left). Thanks for that.

  12. I had this exact same problem. Another way i fixed it was opening the “on screen keyboard”. There is an extra button on the “on screen keyboard” that is not on my physical keyboard. To the right of the spacebar there is the 2nd Alt key, a 2nd windows key and something that isnt on my physical keyboard and finally Ctrl. I clicked the unknown button on the “on screen keyboard” and i can now type C H T and V again. Hopefully someone who knows what they are doing reads this and can add it to the list.

  13. Many thanks for your posts. The RIGHT Windows key resolved the issue in my case, which affected v, c and h keys. I’m on Windows 7 64 bit, and the issue only just started this week! Uppercase (SHIFT + v, c or h) was OK, only some applications were affected, restarting applications helped too – arggh!! :)

  14. Just had this problem on my laptop. I have a Windows 8.1 laptop and I can confirm the problem continues even when trying to use the on screen keyboard. Thank you for posting these solutions with two quick taps of the windows key I have full functionality of the keyboard once more.

  15. Eish I’m having the problem of @ and “, when I press @ I get ” and when I’m looking for ” I get @. Its a big problem now. My “p” is also giving me problems, when I press P I get ;p, I don’t know what’s happening, please help. I’m using toshiba

    1. Yeah, katleo, that’s a new one for me. Have you tried attaching a different keyboard? You may also want to check your keymapping (make sure you are using a US keyboard layout if you are using a US keyboard for example).

  16. Still hoping for some new answers in the future. I have tried all of these options and it will still not work for Microsoft Office Communicator Web Access. Its only a lower case t that will not work. A capital T will. Its only in that program, everywhere else the keyboard is fully fuctional. This is on Windows 8.1

    1. Sorry, Tanner. Every trick I have is in that list at the bottom of the post. You could try re-installing Office Communicator (or possibly switching to Lync?). (I can recommend using Revo Uninstaller’s Advanced mode to remove all traces of an application before re-installing it.)

  17. Fixed! Thanks!

    I had this problem on my PC: Shift+c and shift+v did not do anything. When I set my windows to sleep mode it woke right up again. When I took the batteries out of the keyboard the PC would stay in sleep mode. After checking all buttons I found that the F2 was stuck. When I pushed it, it popped back up. Then the shift-c worked again. Same with F8 button and when I took that out, the shift-v worked again.

  18. I had this problem pop up on my windows 8 login screen for my Lenovo y40 bought August 2014. I did try the on screen keyboard, failed. Tried windows keys, failed. I discovered that it would type capital H if I used shift or caps lock, but not lowercase. Finally did restart, which fixed the problem

  19. I’m using Win 7 64bit on an ASUS laptop, and I had this issue. My fix was a bit different than any listed here, and involved an application that had plugins in other applications. I might do further testing to see if the plugin causing the issue can be changed enough to not cause the issue, but for now, I just disabled the plugin.

    For me, it was the In-Game chat plugin for Trillian. For some reason, my games would read the ‘M’ key for shortcuts and commands, but inputting words into the interface (like for a name) was a no-go because certain letters wouldn’t type.

    Interestingly enough, this also affected my Photoshop CS5, which is definitely not a game. I did my first test with the disabling of In-Game Chat on Photoshop, then tested Dragon Age: Origins today to make doubly sure. And disabling that plug-in was the fix I needed.

    Soooo, moral of the story: Look at what applications are talking to each other, and see if there’s a setting or plugin in one that is affecting others.

  20. This must be among the oddest bugs. I rebooted computer and it did nothing, then I read about double-tapping the windows key, did that and now everything is fine again. If someone just told me about this bug I would not believe it actually exists.

  21. I just had this same issue in Chrome on a windows 8.1 laptop. didnt see the other solutions but closed and reopened Chrome and it works fine now. I was missing the c and h buttons. didnt try the others to see if they were affected too, but it was only in chrome that this happened. very strange bug indeed. i did just install a new plugin for chrome, the vlc plugin. I wonder if that could have anything to do with it. but it works fine now and in the future i might try the double tap on the right windows button instead of relaunching chrome.

  22. I have a different problem recently… these keys [e,q,tilde,tab,capslock] sometimes work, then sometimes not.. all above fixes doesn’t work for me.. I noticed that these keys work/doesn’t work the same time.. please help…

  23. I have had this problem a few times since buying Lenovo computer with Windows 8.1 in 2014. I just had again – with c, v and h keys disabled in chrome, office write and I would guess all applications.

    Pressing Windows key and Alt key together fixed it! Note that pressing windows key and function key doesnt work in 8.1, because this is set to toggle to the crappy menu screen in windows 8.1.
    Note pressing windows and alt again does not create the problem. I use Chinese IME as well on my computer, and note others mentioning the language input as possibly related cause. But I looked this up on many forums, and cannot find any egghead geek yet who seems to have definitive answer to the cause.

  24. Just had the same problem with windows 8 using google Chrome, a few letters wouldn’t work anywhere in chrome but when I switched to Word, bam they were back. I used your suggestion to push the Fn and window key and it fixed it….I don’t know why exactly….but it did. Thanks beating this problem till it gave you all the answers it could! As I can see you have helped many a person.

  25. I work in an IT department and have for years and I have only ever seen this happen once. The user had a 32 bit windows 7 OS. I don’t know the service pack he was on. The letters were exactly the same. v,h,c and t. The application effected was Lync 2013.

    We fixed the issue by running a repair on Office 2013 and restarting the computer. I started the repair before finding this blog or I would have verified some of the other fixes.

    Interestingly enough, a work around would be to just use capital letters in stead of the lower case ones. just like the ctrl+, or alt + commands shift seems to be unaffected by the issue too.

  26. None of the solutions worked for me. I have issue with keys 9 o l . right and down arrows.

    Some time this issue will be fixed when I run memory diagnosis at boot time but next day again it doesn’t works.

  27. Strangely my desktop computer is ignoring the c, v & h keys, but only when I try to use search function in Windows Explorer.

    I know it isn’t the keyboard because I have tried 3 different keyboards (wireless and wired) and the problem is with all of them. (Logitech dinovo media, Logitech dinovo edge all Bluetooth and a usb keyboard)

    Unfortunately hitting the windows key doesn’t work (Windows 8.1 pro 64 bit) all it does is bring up the start menu.

    Tried all of the above mentioned solutions with no success. Neither does restarting Explorer.

  28. Thanks a lot for this page!

    I don’t have a RightWin key on my keyboard and I don’t want to connect USB keyboard everytime it happens, so I wrote a one-line application which imitates pressing of ‘RWIN’. It worked!

    In case anyone interested, I can send the exe file or the source.

  29. I have this happening to me. Keys “broken” = G H ‘ Ctrl (four keys total). System = Tablet, Surface Pro 3, Windows 8.1 Pro, 64-bit, 4 GB RAM.

    I have tried all the recommended fixes in the above post minus the right CTRL key as I need to install the emulation tool and not sure I want to trust the sources. I’m currently using the tablet keyboard which works fine although long-term is not ideal as my wrists need the ergonomic keyboard.

    Anyway, I wanted to let everyone know what DID work BUT only for about 60-seconds (I know, weird and I wouldn’t believe it if I didn’t see it myself).

    What worked to fix the keys (for about 60 secs) was changing the language setting:
    Settings => Control Panel => Region => Format SELECT DROPDOWN => change FROM: English (United States) => Select: English (United Kingdom) => click apply. (“Broken” keys worked about 50% of the time I pressed them for about 30 secs and then they stopped.

    Super weird huh! It tells me that the “bug”/issue is somehow tied to the language settings.

    However, I still need more recommended solutions if you have anymore let me know. (In the meantime I’m going to see how the right CTRL key emulator install works, or not.)

    Thanks all!

  30. some keys: w, r, p, ], page up,tab, down arrow, 2, 7, 9, will keep type the = until I press other keys which is not affected. and fn + windows key fix it! thanks to you.
    But the page up keys is not fixed by this actually. and some keys like space and ‘h’ are slowly respond to. do you have any suggestion for this? will appreciate your help if any, thank you!

  31. My keys that didn’t work were c, h, and v. I noticed that when I clicked shift+c, to type an uppercase c, it worked. Caps did not work. I also tried the touch screen keyboard, and alas, it did not work. All the applications I tried would not work, not that I tried many. Thank god for this page, I double-hit my windows button on my keyboard. Now I’m fine.

    Dark Lord Satan

  32. I had that same problem( c, h, v keys not responding ), so I googled the problem. It brought me to this web page just as I noticed my left Windows key was stuck down. I pressed and wiggled it a little and WahLah the problem is gone. The problem is definitely with that button, I probably hit by mistake…

  33. I have NEVER had this problem until tonight… and I’m on Windows 8.1 – brand new machine – Dell – with Office 365 – using Chrome – all of a sudden C, T, V quit working in my browser only. Found your thread, started clicking every combo of F+Win & CTRL + Win and it took several tries to finally get it working. As you can see, I can now use those keys in the browser… I was using them in Word and the touch screen keyboard would show the letter and act like it was typing it in the browser, but it never typed… so i tried the physical keyboard and my touchscreen version. Thanks for posting this thread – I was in the middle of something I couldn’t reboot or shut down… you saved me!!

  34. 1)
    Pressing keys in fast sequence make you able to use the keys that don’t work. (the key pressed before the not working one must be working)
    E.g -> press ‘h’ but nothing happen
    E.g -> press ‘o’+’h’, and both letters appear
    2) h,y and u sometime
    3) All, even the password insertion in the profile
    4) Win7

  35. I have the same bug repeating over time, and it seems, at least for me, that it is related to sticky keys. And double press right windows key solves the problem.

  36. Hey just ran into this issue today with Chrome. I heard trying to disable (not uninstall) some extentions helps. there’s an option in the hamburger menu (the 3 horizontal lines in the upper right of the Chrome window) to switch to Windows 8 mode. I tried that then switched back and that seemed to have solved it, for now anyways. I have a Dell Inspiron notebook and I noticed that alot of people were complaining about this issue had the same laptop. Just guessing but I think it may have something to do with the Windows 8 hotkey functions since all these keys are associated with them. Maybe glitches switching between keyboard and touch *shrugs*

  37. I had similar problem in Google Chrome web browser and yeah my onscreen keyboard also wouldn’t let me enter certain set of keys but the ctrl+(key) were working. I am using Win 10 on Dell laptop. Mine started working with just double tapping the windows key.
    Thanks for the solution James but do you know what exactly could have caused this?

    Thanks again!

Leave a Reply

Your email address will not be published. Required fields are marked *