Keyboard input ignored for c, h, t, and v keys in specific applications only

Every once in a great while I see this odd problem arise. I have not yet found a solution but when I do it will find a home here.

Basically what happens is I will hop over to a specific application, try to type into that application, and find that certain particular letters will do nothing. This time it was these four letters: t, h, c, and v, but I think that sounds like what it was on other occasions (though I don’t recall perfectly).

Most recently this happened in Outlook. I have seen this happen in Outlook before, but I’ve seen it happen a couple of times in Firefox and once in Opera. It is definitely not a keyboard problem, a driver issue, a problem with the specific application, or a keyboard shortcut issue—nor is it a virus or spyware.

Something as yet undetermined happens in the wonderful world of Windows XP wherein those four letters are completely ignored as input. It only effects a single application when it occurs. No alt-, ctrl-, or windows- commands are executed when any of those keys are typed. I can press the same key, the t say, 100 times and absolutely nothing will happen. Then I switch to another application and voila it works fine. For instance I’ve had to type an e-mail reply into a text editor and paste it into the reply window because I couldn’t type basic words like the.

Using associated keyboard shortcuts seems to be unaffected. As noted I was not able to type the letter v. However, I was able to use ctrl-v to paste into the reply window.

Now I know you’re going to think: “well it must be that reply window”. Again, it’s application-wide. I am not able to type those letters into the search boxes or contacts windows or any other place that might allow text entry—within the afflicted application.

Also, I have seen this on at least three machines where there can be no relation between them (except my smiling face reflected in the monitor). I think I have seen this happen maybe half a dozen times in the last couple of years.

It’s easy enough to fix by restarting the afflicted application, but I am on the path for this one. It’s stuck in my craw so I won’t be satisfied until I figure what the hell is going on.

It has come to my attention this may also effect on-screen keyboards.  Please test this in your case if you are able, and let us know your results below.

I’ll try to keep this up to date concerning my progress, but feel free to share your solutions. I’m all eyes.  (This happens rarely enough that it’s good to have others contributing data.)

(It will be useful to include four items in your comments: 1) your solution (even if temporary); 2) keys effected; 3) application(s) effected; and 4) operating system(s) involved.)

Random Solutions Culled from the Comments:

(In no particular order.  This may not be complete and up-to-date.)

  1. A double-tap of the Windows (or Super) key.
  2. A double-tap of specifically the right Windows key.
  3. Restart the effected application (or Explorer if effected)
  4. Reboot (last resort).
  5. “Detect and Repair” from the Help menu in Outlook (Outlook only)
  6. Press CapsLock and Shift back down to lower case (this is a per letter fix)
  7. Fn key + Windows key may toggle problem on and off.
  8. Region and Language —> Keyboards and Languages —> change keyboards;
    delete all keyboards other than your language and delete all instances of “Ink Correction”.
  9. Disable Sticky Keys (Control Panel —> Ease of Access Center —> Make the keyboard easier to use —> Make it easier to type —> uncheck “Turn on Sticky Keys“)
  10. Remove all keyboards from the Device Manager and reboot.
  11. Login to the effected machine via RDP and then return to the machine and login locally.
  12. Laptops may have to use the Widows key on the laptop and not a secondary keyboard.
  13. In Win7 it may be useful to check for keyboard/language changing hotkeys here Control Panel —> Region and Language —> Keyboards and Languages —> Change Keyboards —> Advanced Key Settings

If none of these work or if you have one to add yourself, comment away.

(It will be useful to include four items in your comments: 1) your solution (even if temporary); 2) keys effected; 3) application(s) effected; and 4) operating system(s) involved.)

Share

314 thoughts on “Keyboard input ignored for c, h, t, and v keys in specific applications only

  1. ok i cant write, (i just remembered, so im writing in word), but its great that someone is looking for an answer… kinda annoying, since its primary keys.

    1. Thanks for stopping by. If you have more details about how your issue (doesn’t) work, I’d love to hear about it. Any specifics about conditions under which this happens/doesn’t happen. How do you have to correct it (restart app, reboot, &c.)?

  2. I am having the same issue (sorry for bringing up an old thread like this)… I was hoping you guys had a resolution? The problem is only affecting 1 machine at the moment at the company I work for and I do not see any odd programs running in the task manager (ie something capturing keyboard input and stealing the C, V, H, or T keys if outlook is in focus)… but I agree… ctrl+ works, alt+ I have not tried… nor windows+, although I don’t know what windows+C,H,T, or V would do.
    Seems to only affect outlook 2003 for me.

    1. Super-T switches taskbar focus from item to item (then Enter will Minimize or Restore as appropriate), but I don’t think the other three letters have a key-binding with Super.

      I doubt it’s malware taking the keystrokes. Seems pretty unlikely for two reasons: what would be the point and I’ve not seen any correlation between detected malware and this problem.

      I’ve never seen it happen on many machines at once. I have only just seen it occasionally strike one machine briefly. No sense at all.

      Oddly enough, I haven’t seen a machine with this specific problem since I wrote this article. I’m sorry to have no definitive solution to offer. I look forward to discovering one. Please report back if you find a real solution.

      1. well, not sure if this works for everyone or just me, but I did a “detect and repair” from the help menu and it seems to have resolved the problem for now. I am hoping this to be a permanent solution as it has been good for 2 days now which is a lot longer than previous. If not, I am going to presume it is related to some other piece of software (or outlook plug-in) that is incorrectly stealing the input when it sees outlook as being in focus.
        I suppose if I notice it again, I could take a poke at netstat (or ethereal) and look for odd network traffic, but I doubt it is a virus as well. We keep our antivirus up to date at our company, and you reported this problem back in 2008 and I have found another thread reporting this problem back in 2006. If it was virus related, I imagine they would have caught it a long time ago and/or changed the keys it affects (to reduce the chances of finding a googleable solution).
        Thanks for the info though. And I will post my results.

          1. with a restart of the affected program it would resolve the issue temporarily as would a reboot. Detect and repair of outlook resolved the problem from what I can tell, now it is an issue with windows/remote desktop. But this problem seems unrelated. For those curious: the new issue is that the super key (which I mistakenly called the “windows” key earlier) seems to be pressed from a software perspective. That is, when you press only the L key it will lock the computer, or the R key will bring up the run dialog. This problem seems to only occur when using remote desktop, so I think it is a software issue now and the C, H, T, V key issue has been resolved.
            Thanks for your help everyone.

          2. Yeah, I’ve seen the Super key get stuck in RDP sessions. Really annoying, especially if you (like me) can touch-type rapidly. I’ll get a sentence typed before my brain realizes that explorer windows are opening (Super-E), the run dialog is popping up (Super-R), and I’ve locked fucking session (Super-L). If memory serves, you can simply strike the Super key and reset that lock (this will cause the Start menu to fly-out so I usually give it a double-tap). If that doesn’t work let me know and I’ll look back through my notes.

            It’s only a mistake to call the key the Windows key if you are talking about a non-MS keyboard. Though it’s the same key, it won’t have the Windows logo on it. You’ll find it referred to both ways around the Net. For my part, I say Super because it’s operating system and manufacturer neutral.

  3. Glad I found this site. I have been having the same problem with a work laptop. Its an HP EliteBook 6930p and its in an HP docking station. I was originally using a PS/2 keyboard (its an old MS natural keyboard) plugged into the docking station and the c,h,t and v keys would occasionally stop working in a variety of applications. I initially solved the problem by moving to a standard USB keyboard.

    I have just had to start using the ps/2 keyboard again and the problem showed up again. I just used the the solution mentioned by JamesIsIn of pressing the Start/Super key twice and I can now type the c, h, t & v keys in an application which they weren’t working in.

    Thanks for the help

  4. I just had this crop up again, and I’m glad I stumbled here from Google. I originally searched with “c, h, t, and v” in a different order >_<.

    Tapping each of my meta keys several times just made the problem go away in Firefox. In the past two days, this has hit Pidgin twice (I just restarted it both times) and Firefox (a pain to restart, because of all my open tabs!). Before that, though, I hadn't seen it in three years.

    Three years ago, I think I may have narrowed it down to one application that affected others. VNC, perhaps? I've recently gone back to RealVNC (rather than TightVNC).

    I think I had a Thinkpad T41p three years ago, and now I have a Thinkpad W500. I've been using the same PS/2 keyboard that came with my old workstation (the new UBS keyboard I got looks the same, but feels horrible). I remember the old Thinkpad often had an issue with meta keys getting stuck when using an external keyboard, but that wasn't per-application.

    I wonder what the common denominator is for all of us with this problem…

  5. Glad I found this, I was having problems with c, h and v when using Firefox with Windows 7. Pressed the windows key a couple of times and it’s fixed

    1. Great to know you fought it back this time.

      Windows key, eh? New one for me. I’ll have to give that a go if it pops up again. It’s a real bugger to troubleshoot because it’s so random and rare.

      Thanks for stopping.

    2. sigh. I’ve been hit by this bug too. Very odd. I’m using Windows 7 Professional with an Apple aluminium keyboard. Interestingly, although C, V and H keys don’t work, if I press SHIFT and C V or H, then I do get a capital letter C V or H. As a very annoying workaround to get a lower-case C V or H I need to put Caps Lock on and the press SHIFT and C V or H it does a lower case one. The apps affected for me are Chrome 13 and Firefox 6.

      1. Neat trick using the CapsLock key and then shifting back down to lower case. I wonder if that works with the CTRL combinations as well. I’ll have to try that out if (when) this comes up for me again.

  6. Outlook keys will stop working. If I restart outlook the keys are back. I have lenovo t410. Outlook 12.0. I do have VNC on the machine. I also use synergy between computers. I’ll have to try the super key solution when it pops up again.

  7. I encountered both issues, the one where pressing “C” would open My Computer and “L” would lock it, and the problem where c,h, v, and possibly t just stops working in Outlook. The first problem is resolved by pressing the windows key twice or pressing windows key + E or C. That only fixes the problem temporarily though. To fix it permanently you have to mess around with the sticky key options both in the RDP session and the local workstation. Keep in mind it may also be a legitimate issue with the keyboard and may need to be replaced.

    Recently i encountered the c,h,v,t keys not working on Outlook. I haven’t found a resolution to this yet but the user says it only happens when he steps away for some time. The only power save settings he has set is to turn off the monitor after 20minutes, everything else stays on. I’m going to try the repair option in Outlook, hopefully that will do it. I’m not sure if it will though since 80 other users use the same RDP server and nobody else has the problem.

  8. (to add my 2p to this “eternal” thread… ;) )

    I’ve got the very same problem, only it’s on a brand new pc with a brand new wireless keyboard, running on Windows7.
    Didn’t even notice the t wouldn’t work… but c, v and h for certain!
    And it’s the first time I’ve ever had it

    it’s definitely NOT keyboard-depended, since, once it’s gotten into one program, the parallel PS/2 keyboard doesn’t type those letters either.
    Only help: close the software and open it again.
    only if it’s gotten into the Windows Explorer, I need to reboot.

    Will try your super key-solution next time it happens. so annoying!!!

  9. Just had the same issue on W7 while using Adobe Illustrator. It happened several times in which seemed to transmit the problem to other programs like the Windows Explorer and Google Chrome. Tried the solutions named in previous comments with no luck. Restarting Illustrator solved the issue temporarily, but after a while the keys refused to work again.
    Solved the problem almost randomly by passing my finger by each and every key in the laptop keyboard (i was using a USB keyboard on my laptop). After that lapse of chaos brought by the function keys activating stuff, the c, v h and t letters regain function.
    The issue hasn’t appeared again.
    Third one with this problem in april 2011. This must be a popular post.

    Ps: Grammar Natzis be kind, the Internet tough me the language.

  10. I can’t believe this problem has been around since (at least!) early 2008! I started having this problem with Windows 7 just a few months ago, but assumed it was a W7 specific problem. As other users have noted, it’s not limited to a specific application – at various times the keys have stopped working in Visual Studio, UltraEdit, Outlook (just now, which is what prompted me to search, again (!), for a answer) and even notepad. Each time the only solution I could find was to close and reopen the application. Then the problem would disappear for a few more weeks…and then just as suddenly appear again!

    Irritating is not the word :-) Sadly it looks like we’re not really any closer to finding out what’s causing the problem, let alone finding a solution … :-|

    1. It’s been around a lot longer than that. Sorry not to have a solid answer as yet. It is just too (seemingly) random for me to do any real trouble shooting. Let us know if you have any new insights.

  11. I’ve nailed this down to the Windows key causing it, but it’s not resolvable in my case with anything except restarting Outlook.

    The Windows key problem and RDP has been shitting me for years, so I’m well aware of it and highly trained at swearing and smashing the Windows key a few times. This particular issue is something deeper in Outlook. Synergy comes up a bit because it seems to exacerbate the existing RDP/Windows key issue – but it is not related to this Outlook issue. I’ve had it with and without Synergy.

    auuser_825 post on here is me:

    1. Thanks, Ryan. I don’t recall a definitive requirement for the use of the Windows key to cause this problem, but it may well be such as you describe in the thread to which you linked.

  12. just had this problem arrise in our office. computer across roughly 250 on campus does it and it didnt start till we installed our new VoIP phone system and its related outlook plugin called Executive Insight. so far its only in outlook but i am keeping a close eye on it and have informed the user that i havent found a definitive solution yet. just restarting outlook fixes the problem for now but i dont know for how long between instances as as it just started yesterday. here’s hoping

  13. I’ve had this problem for a while. Running Windows 7 Ultimate 64 bit on a Alienware laptop (if that matters).

    I’ve seen the problem in Visual Studio, Word and most recently today in Windows Explorer!

    I’ve finally tracked down the issue with my computer anyway.

    I can toggle the problem on and off by holding down the laptop ‘FN’ key and then pressing the Windows key. This works for any application that is currently focused.

    Hope that helps other folk out there. I am so glad I don’t need to reboot to resolve the problem now.

  14. Well, this may or may not be an obvious point, but after reading this thread and several other similar ones, it’s clear that for what ever reason certain applications are detecting the windows/super key as being in a held down state. This would also explain why tapping it a couple of times temporarily resolves the issue. Of course, neither the underlying cause or a permanent solution are quite so obvious.

  15. Nice to see that there’s so much company on this one.
    Dell Latitude E6410, no external keyboard, Synergy Client
    Dell Precision 380, Microsoft PS2 keyboard, Synergy Server

    This happened when I had Outlook up and was typing a reply email. I had to step away, so I manually locked the laptop, then the desktop (Win+L).
    When I came back about 20 minutes later, I unlocked the desktop and then the laptop.

    When I went back to complete the email, it was happening.
    Typing directly on the laptop keyboard showed that it was also dropping the chtv keys, so it was definitely not linked just to the PS2 keyboard. Also worth noting – no other keys were behaving as if the super/win key was depressed.

    Shutting down Outlook worked to clear things up temporarily, but every time I locked that system with Outlook up, the keys went dead again.

    After a reboot of the laptop, it seemed to clear it up (meaning that I was able to lock and unlock that screen without losing the chtv keys).

    -dan

  16. In my case, it seems that the c, v, and h keys are the only ones affected. I’m on 64-bit Windows 7 and this started after I accidentally hit a bunch of random keys because I got startled. This is affecting more than one window on my system including Firefox and Explorer (I do not mean Internet Explorer here). It only seems to be affecting programs that were running when the symptoms appeared. For example, closing and re-opening Notepad++ fixed it for Notepad++.

    Some interesting facts:
    1) Pressing the shift+ works. So I can type CVH by holding shift.

    2) Turning on capslock and then using the shift key allows me to type the lower case letters cvh

    3) I’ve noticed that if I use Microsoft Spy++ to monitor messages to “All Windows in System” and then selected just the keyboard messages. When I then click on the desktop and hit a working key, three messages appear to be generated:
    a) a WM_KEYDOWN message
    b) a WM_CHAR message
    c) a WM_KEYUP message
    When I press a key that doesn’t work, only one message is generated, the WM_KEYUP message.

    4) I have a Microsoft keyboard. If
    It looks like something is happening involving window messages. I just have no idea what.

    Finally, something to note: I don’t actually have any experience using Spy++ so I could just be using it wrong.

    Cheers.

      1. Windows fires multiple events for each key press, usually a “Down”, “Up” and “Pressed”.

        The keyboard API works like a chain – each layer intercepts the presses it wants and passes the rest along. I wonder if this might be a badly written keylogger?

        See here for more info: http://www.codeguru.com/vb/gen/vb_system/keyboard/article.php/c4831/Managing-LowLevel-Keyboard-Hooks-with-the-Windows-API-for-VB-NET.htm

        Note how ~line 80, the app is deciding whether or not to swallow the event.

  17. Worked for me. CCCHHHVVV :-)
    What a weird solution for a weird problem, hehe.
    Thanks for the website! I was scared i’d go c, h, and v-less forever.

  18. I thought I was going insane… I’ve had this problem with Windows Live Messenger 2011 on Windows 7 Pro x86, and it’s most frustrating… if I restart WLM, it works fine, until I hit the Winkey again. IntelliType’s little Key Press Utility was showing that, yes, I was mashing the keys like there was no tomorrow.

    Sometimes it affects several programs at once, sometimes just one (including but not limited to Firefox, Chrome, Outlook 2010), but just now it was only in WLM after hitting the Winkey.

    Would you believe, that, half way through this comment, it happened in Chrome? Then again, I did try hitting Winkey+C, H, T and V in Chrome to see what if anything they did… only Winkey+T did something (scroll through taskbar icons).

    I use a ThinkPad SL400 and a Microsoft Wireless Keyboard 3000… maybe it’s an IntelliType issue?

    1. If you can think of a way we could test to see if it’s an IntelliType issue that would be great. I haven’t seen it in a long time and this seeming randomness makes it all the more frustrating.

      Oh, and switch to Trillian to get rid of MS’s chat client altogether.

  19. I had an employee complain of this very issue today. Thankfully I found this website and although the diagnose efforts claimed nothing was wrong in both Excel and Outlook 2010 versions…mysteriously the problem disappeared.

  20. One problem we have is that we don’t know how to trigger this issue, although if there was, I suspect we would have an answer as to the cause. Does anybody remember what they were doing when this issue first appeared?

    On another note, as I stated above, the issue does not seem to affect applications that I run AFTER I notice that the c,v,h keys have stopped working. Closing and reopening the affected applications (or rebooting if Explorer.exe is affected) has worked for me? Has anybody else had this problem persist after a reboot or close/reopen?

    1. My experience has been that reboot = reset; it might come back later but rebooting will get rid of that instance.

      I have seen nothing but diversity in what starts this. (I support many desktop systems and this shows up randomly on diverse systems, applications, users, and scenarios.)

  21. Had this problem today for the first time. I was using Google Chrome in Windows 7 64bit. Other programs worked OK.

    I’ve had similar problems before, but just pressing the ‘windows’ key, or disabling sticky keys (press shift 5 times) usually fixed it. These things didn’t work today.

    The problem was the same as for other users, CVH keys not working (T was), and shift allowed the capitals to work.

    I tried restarting Chrome, but got the CVH keys back only temporarily.

    I read all the replies, until I got to SteveE’s:
    I can toggle the problem on and off by holding down the laptop ‘FN’ key and then pressing the Windows key. This works for any application that is currently focused.

    I’m on a desktop, with a Microsoft Wireless 6000 v3.0 keyboard, but it got me thinking. Earlier today I was trying to find a key that I don’t normally use to see if I could assign it as a hot-key. I wasn’t able to do what I was trying to do, but in the process I pressed a key that I’ve never pressed before. It’s on the top row of function buttons on the keyboard on the far right, and looks like a picture of a monitor with several windows to the side. I’m not sure of it’s exact function, but appears to have the same effect as pressing ‘Windows + D’, ie, show desktop. I just pressed it again and, voila, CVH are now working again.

    This problem reminds me of getting caught out trying to log on to a laptop with the numlock on :)

    1. Thanks for all the additional information. I tried SteveE’s solution to see if I could break my system (Windows 7) and I was not able to disable the keys using Fn-Windows. I tried a few function keys on this laptop (those enabled by also pressing the Fn key) to see if any of them would break my system. Nada. This leads me to believe that this set of symptoms may have multiple causes where one solution or another may then remedy the situation. Glad you got yours working again.

  22. i was having the same problem, i will try your solution… funnily enough, it happened in internet explorer, but not in every single text field, those keys worked in some but not in others… but i was transferring files across to my computer from another one on the network at the time, and it’s interesting you say this relates to remote desktop sessions, since i am logged into that computer remotely to transfer the files

  23. I just recently started having this problem and i came across this website. I’ve read through all the comments – for me it is also c, h, and v. I’m running W7 64 bit on a HP pavillion dv6 using google chrome. So far, it has occured in chrome and the video game “Starcraft 2.” Tapping the windows key and the function key trick both have not worked. Reboots temporarily fix this problem but I am going to try to find a solution once and for all. Will post back later if I find something!

  24. Thank you for addressing this interesting problem, but I have not found any remedies to my “v” key – I am able to copy and paste it only to insert it into any text.
    alienware m17x laptop windows 7
    on initial start an error message starts with the request to choose you system to boot – I have tried last safe start and just windows 7.
    after complete boot a little ping sound alerts me to the continuation of the problem – check it out –
    I can open either word or the start menu to see the problem fastest:
    in the start menu in the search dialog box, a string of v will populate; or in word, a continuous line of vs (I saved it as my source to copy paste from as, given my name and email address, I need vs constantly)
    This continues until I stop it with typing space bar or ctrl or alt or num lock, etc. and then it goes dead. It feels like it is short-circuited on, and then eliminated from the circuit with interruption.
    This is independent of outlook (not used) and shift/caps does not allow typing.
    Also, last night (the first I noticed this) C and H were also affected, but I took off the keys and brushed and tweezed out debris, and they began working! Not v.
    I tried system restore, and that did not help.
    I didn’t see anything interesting in devices/drivers
    I ran a malware battery of scans.
    I am out of ideas!

    1. Yours sounds like it might even be a hardware issue. If your machine is still under warranty, make them give you a new keyboard and let us know if that eliminates your troubles.

      I haven’t seen a system where on boot the V key (or any key) acted like it was being held down. Maybe another visitor can offer a different experience.

  25. I’m loosing c, h, t, and v in firefox. Running win7 on a dell inspiron. Wish someone would figure it out, seems pretty fishy to me.

    I dont’ know how to fix it, but I ran into it today on my win7 laptop, it happened in firefox. It was c,h,t, and v. Restarting the app resolved it, but it returned later.

  26. I have this problem on my Windows 7 64bit. This affects my Chrome browser + Mirc 7.22. My “t” works but “c v h”‘s doesn’t. Pressing shift makes them capital yes but pressing other combinations doesn’t fix the problem. I need to boot my computer. I believe this started when I put two mouses on my computer, I don’t know if that made some crap with the drivers on input devices but I don’t want to reinstall Windows 7 before trying other things out. I’m out of clues!

  27. Can’t believe this issue has been going on so long! Having the same with a user at my place. Same letters. Windows Key press doesn’t stop it, she has to restart Outlook, but it’s happening almost hourly. Have rebuilt Outlook Profile and tried an Office Repair so far, and will be taking another look later. Will repost if I find a solution!

  28. This may be signifigant of a larger problem. Tonight I rebooted a Dell Inspiron with 32bit Vista fir an svchost.exe memory leak issue (due to windows update not updating itself…)

    After a full system format and reinstallation via a factory image, the T, H, and C and V keys completely stopped responding, but only lowercase, just as others here have noted. They worked when I press the shift key.

    This was on a freshly rebooted machine that has never seen the internet or had any programs installed except windows vista and some dell stuff that came with it. After a few minuted of jamming keys, poof! the problem went away. Here is the eerie part:

    It only affected Windows. That is, notepad.exe, internet explorer, all kinds of programs, allowed those keys to work fine. It was just the windows start menu box, file menu address boxes, and other windows related text areas that were affected.

    I am curious: could this be a little boot sector virus/bug that has somehow survived the system format? I did a quick format using the /q switch, does that format possibly not clear the boot sector or some such strange thing? How in the world could this happen to a fresh factory imaged system on first boot?

    So wierd. Anyone ever really figure this issue out? If so, please email me, thanks. Would love to know if this is related to my svchost.exe memory leak issue… Especiazlly since it totally prevents someone form typing the prblem “svchost.exe” into a search engine to aquire assistance- it would be a stroke of genious really.

    Actually, while typing this my system locked up and explorer had to be reset. This ‘keyboard problem’ is totally a deep Trojan. It allows remote access to a hosed Windows system. The person with control was monitoring me while I typed and then attempted to shut the system down. I killed the trojan service, somehow it looks like maybe Rasman.exe or ProfSvc running through svchost.exe, or something hiding even deeper…

    Good luck to anyone dealing with this, hope your issue is not as wild as this one.

    1. My impression is that it’s a Windows bug which has never been patched (and which has ported across Windows versions). I suspect it relates somehow to Office (though it has broken in non-Microsoft software exclusively for certain sessions), but I can’t say absolutely. So perhaps something like Office is installed and it changes some something which periodically manifests itself, in one application or others, as a loss of key functionality given particular circumstances. In Microsoft’s defense, it does strike me as a giant pain in the ass to troubleshoot. But still: it’s been around for nearly a decade.

      Oh, you might have luck typing into some application which does happen to be working (Opera or a torrent client or anything really) then copy and past into the effected application. That’s worked for others in the past.

  29. In Windows 7, go to Region and Language settings -> Keyboards and Languages, and click on change keyboards.
    Delete all keyboards other than your language, and delete all instances of “Ink Correction”.

  30. Similar problem, Win7 x64, Opera 11.60, the C, H & V keys weren’t working. All other letters did (including T). Noticed that shift + C worked while caps lock then C didn’t. Also, the keys worked in every other application. My keyboard has had a history of the ctrl or alt keys getting ‘stuck’, so I mashed them a few times with no luck. Tried the Windows key as a few people have suggested and that solved the problem.

    It might be worth adding the Win key ‘solution’ to the main post, since many people may not read the comments, and this post was the first result on google.

  31. yah, looks like it is caused by something related to multiple installed keyboard-layouts. allthough i have them (de, en) installed for over a year, the problem occured only right now.

    i triggered it by nudging the windows to the left / right side of the screen via super+left/right cursor.

    deinstalled the additional keyboard and “everything works” again.

  32. I’ve had this problem intermittently for years but for whatever reason over the last few days it became really persistent. So I read all the above – nothing worked.

    Until, that is, I tried hitting my *right* windows-super/whatever it is key. I had been fiddling with the left one assuming the two keys were equivalent. It seems not – hitting it twice fixed the issue. For me anyway :)

  33. It happened to me yesterday using Windows Live Mail on Windows 7. The lower case “h” and “v” stopped working in the middle of typing an email. As with all Microsoft products, I believe the alignment of the stars has a great effect upon performance and reliability.

  34. hi there,
    i encountered this problem for the first time today and as a technical user it really confused me how this could be happening! i imagined myself someone else calling for help telling me this and how i would react. anyways!.. i’m so glad i read all this thread since the suggested fixes had not worked for me and the last one by Paul was it! all the time i was also pressing the *left* windows key and nothing.. so yes, pressing the right one took care of it, what an easy fix without having to restart applications.
    thanks for this post!

  35. I’ve experienced this problem today also. It seemed to occur after locking my Win 7 laptop with the key on my Toshiba laptop. Hitting the Windows key twice seemed to fix it fine for me…
    Many thanks for your help. A fix of the fundamental problem would be great but sometimes you need to be satisfied with a quick workaround :-)

  36. My while using skype, my h, c and v didn’t work. t did seemed to work fine, though. the double-tapping of the right windows key worked – left did nothing.

  37. Thank you for this article. This little beast has plagued me for ages, and yet it seems so random when it happens or goes away. I also had the missing “c”, “h”, “t”, and “v” keys. Oddly enough, I could work around it slightly by turning on caps-lock and pressing “Shift-missingkey”, and that would give me what I wanted. So far the top suggested fix, tapping the windows key twice, seems to do the trick. Thank you again.

    As an FYI for the interested, this was affected by input on my laptop both for the native keyboard, and also for the keyboard attached to my PC, which was being shared via the open source application “Synergy”. Along with the caps-lock + shift workaround to produce the lower case character, it points to something odd in the bowels of the system that is receiving but ignoring the input.

  38. I was just using a Web form from Lenovo (a survey for site use) when I was not able to use the r, s, t, & u keys—but only while in that form. All the rest of Opera worked as expected as did the remainder of the operating system. Once I finished that survey the problem was gone. Not sure if that perhaps related to the JS used in the page or if it might be also related to this long-standing Windows bug, but I figured I’d throw this in here as well just in case.

    (Windows 7, SP1, 64 bit, Opera 11.62 1347, Lenovo t61s)

  39. I am Having the same problem. All of my keys work on FireFox, but if i try to use the H, C, or V key while renaming stuff on my explorer they do not work. I can use CTRL+C, CTRL+V etc… but the keys themselves are not working. Any help is appreciated

  40. Double tap super key fixed this for me! Problem was in word! Shift was working but capitals only!

    Really appreciated finding this page!

    Thanks

  41. yeah!!!! CVHCVHCVHCHVCV

    Thank you thank you… what a nuisance this has been! It was really disheartening to start at the top of this article seeing posts that date back 4 years ago – with no solution, finally a few years later and couple operating systems later, we have a simple solution. whew.

  42. God bless you and thank you so much for this helpful blog site. I just recently had my Dell Vostro laptop completely fixed. I had the hard drive, keyboard, and motherboard replaced. I was having similar problems with the keyboard beforehand. I’m running Windows 7 Home Edition. With the new system, I was not having any problems until the last few days after downloading a trial version of Microsoft 2010 from http://www.microsoft.com. I wonder if it has anything to do with the Microsoft software in particular. I was having the problem with only the c,h, and v keys in Google Chrome, but the keys worked in Excel. After reading the blogs, the suggestion that resolved it for me was holding down the ‘Fn’ key and pressing the Windows key.
    Again, many thanks.

    1. While I suspect it is possible that installation of Office (2010 or otherwise) could relate to the matter (I don’t recall a specific machine where I saw this arise which didn’t also have Office installed), I can’t say that I have seen a direct linear connection between the rise of this problem and the installation of any particular software. Glad you were able to find a fix that worked for your system.

  43. This has just happened to me with the ‘h’ and ‘c’ keys in windows explorer on Windows 7 Home Edition. I believe the easiest solution would be to restart the computer, but as mine is currently downloading files, I cannot. I’ve read some of the comments already and it seems you all are having problems in Microsoft Office programs, as I am having it in Windows Explorer, and only when I try to rename a file or use the ‘search’ function. If anyone could, I would love to know how to fix it for any future problems or if you get back to me before mine is fixed.

  44. I am experienCing tHis problem now. For me it’s the CVH keys (Please excuse odd caps). Win7 Ultimate x64. This seems to happen after I’ve been RDPing.

    Preiously, it was only 1 app (Maya), tHis time, It impacts all apps inCluding tHe start menu, exCept tHe typing area of “keyboard” in tHe Control Panel.

    I also HaVe an issue in tHat some Hotkeys are broken (eg CTRL-ALT-RIGHT) in VLC doesn’t skip forward.

    By going in to VLC and re-setting tHe Hotkey, I Can see tHat VLC deteCts it as eg Ctrl-Alt-{Meta}-RigHt.

    THis leads me to tHink tHat it’s an issue wHere Win tHinks a key is jammed down. Replugging kbd as no effeCt and I don’t want to reboot as I’m in tHe middle of a long render.

    VERY annoying!

    1. That would seem consistent with the idea that the Windows (Super or Meta) key is somehow stuck in the on position (virtually, programmatically, or digitally rather than physically).

Leave a Reply

Your email address will not be published. Required fields are marked *

You may use these HTML tags and attributes: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>